Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#72032 - [linux] regression prevents bluetooth from working on 5.14 with some chips

Attached to Project: Arch Linux
Opened by Fran├žois Guerraz (kubrick) - Sunday, 05 September 2021, 13:36 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 09 September 2021, 00:09 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

problem reported hereCAAd53p6wi7pk6yFgTnG-JDd9e4zCn3F40bioYyGbAqYg5kMHZQ@mail.gmail.com/T/"> https://lore.kernel.org/netdev/CAAd53p6wi7pk6yFgTnG-JDd9e4zCn3F40bioYyGbAqYg5kMHZQ@mail.gmail.com/T/
and here https://bugzilla.kernel.org/show_bug.cgi?id=214273

since 5.14, and I have had to revert 60789afc02f592b8d91217b60930e7a76271ae07 so that bluetooth works again with a 8087:0026 Intel Corp. AX201 Bluetooth on a Dell XPS 9300.

It doesn't look like a fix is queued yet.

This is the dmesg:

------

[ 16.531286] Bluetooth: Core ver 2.22
[ 16.531306] Bluetooth: HCI device and connection manager initialized
[ 16.531309] Bluetooth: HCI socket layer initialized
[ 16.531312] Bluetooth: L2CAP socket layer initialized
[ 16.531314] Bluetooth: SCO socket layer initialized
[ 16.649289] Bluetooth: hci0: Firmware revision 0.0 build 191 week 21 2021
[ 16.768878] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 16.768883] Bluetooth: BNEP filters: protocol multicast
[ 16.768886] Bluetooth: BNEP socket layer initialized
[ 19.048260] Bluetooth: RFCOMM TTY layer initialized
[ 19.048267] Bluetooth: RFCOMM socket layer initialized
[ 19.048272] Bluetooth: RFCOMM ver 1.11
[ 7043.393714] Bluetooth: hci0: unexpected event for opcode 0x0500
[ 7043.394091] Bluetooth: hci0: Firmware revision 0.0 build 191 week 21 2021
[25277.172310] Bluetooth: hci0: unexpected event for opcode 0x0500
[25277.173307] Bluetooth: hci0: Firmware revision 0.0 build 191 week 21 2021
[32499.334342] Bluetooth: hci0: unexpected event for opcode 0x0500
[32511.644752] Bluetooth: hci0: Failed to read MSFT supported features (-110)
[32605.228360] Bluetooth: hci0: urb 000000009218d7b4 failed to resubmit (113)
[32614.898106] Bluetooth: hci0: Failed to read MSFT supported features (-110)
[32956.688532] Bluetooth: hci0: urb 000000002e945dc3 failed to resubmit (113)
[32966.471603] Bluetooth: hci0: Failed to read MSFT supported features (-110)
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 09 September 2021, 00:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.14.2.arch1-1
Comment by Fran├žois Guerraz (kubrick) - Monday, 06 September 2021, 09:09 GMT
0ea53674d07fb6db2dd7a7ec2fdc85a12eb246c2 seems to fix the issue for me

Loading...