Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7196 - libhttpd missing from apache

Attached to Project: Arch Linux
Opened by Dmitri Melnichenko (zdh) - Thursday, 17 May 2007, 20:55 GMT
Last edited by Jan de Groot (JGC) - Friday, 18 May 2007, 06:07 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture All
Severity High
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

package apache-2.2.4-2 doesn't contain libhttpd, so there are no possibility to build custom modules
This task depends upon

Closed by  Jan de Groot (JGC)
Friday, 18 May 2007, 06:07 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 17 May 2007, 22:25 GMT
What file do you mean? libhttpd.a? That file is used to build a static module like PHP into your apache binary, it's not possible to ship that one in a package, neither is it possible to prepare a package that can be extended that way. What you're looking for is apxs(2) to build modules as dynamic extensions for apache.
Comment by Dmitri Melnichenko (zdh) - Thursday, 17 May 2007, 23:14 GMT
Writing Win32 module first turns me in wrong direction. Sorry for my mistake.

Loading...