Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71946 - [python-gitlab] PLEASE ENTER SUMMARY

Attached to Project: Community Packages
Opened by Krzysztof Krakowiak (pix3l) - Sunday, 29 August 2021, 14:59 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Monday, 30 August 2021, 16:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

All python packages should have removoed (not packaged) '/usr/lib/python3.?/site-packages/tests/', by adding:
rm -rf "${pkgdir}"/usr/lib/python3.*/site-packages/tests/
to PKGBUILD ?(but I believe that it should be included in packaging machinery by default, because thousands of packages from AUR are affected by this and as you can see even some packages from 'community' are affected).


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:

# pacman -S python-pyroute2 python-gitlab
warning: python-pyroute2-0.5.19-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Package (2) Old Version New Version Net Change Download Size

community/python-gitlab 2.10.0-1 2.10.1-1 0,77 MiB
community/python-pyroute2 0.5.19-1 0.5.19-1 0,00 MiB 0,64 MiB

Total Download Size: 0,64 MiB
Total Installed Size: 5,45 MiB
Net Upgrade Size: 0,77 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
python-pyroute2-0.5.19-1-any 654,9 KiB 1264 KiB/s 00:01 [#######################################################################################] 100%
(2/2) checking keys in keyring [#######################################################################################] 100%
(2/2) checking package integrity [#######################################################################################] 100%
(2/2) loading package files [#######################################################################################] 100%
(2/2) checking for file conflicts [#######################################################################################] 100%
error: failed to commit transaction (conflicting files)
/usr/lib/python3.9/site-packages/tests/__init__.py exists in both 'python-pyroute2' and 'python-gitlab'
/usr/lib/python3.9/site-packages/tests/__pycache__/__init__.cpython-39.opt-1.pyc exists in both 'python-pyroute2' and 'python-gitlab'
/usr/lib/python3.9/site-packages/tests/__pycache__/__init__.cpython-39.pyc exists in both 'python-pyroute2' and 'python-gitlab'
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Monday, 30 August 2021, 16:28 GMT
Reason for closing:  Fixed

Loading...