Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7193 - pacman3: -D is missing

Attached to Project: Pacman
Opened by Julien MISCHKOWITZ (wain) - Thursday, 17 May 2007, 18:44 GMT
Last edited by Dan McGee (toofishes) - Monday, 16 July 2007, 02:05 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity High
Priority Normal
Reported Version 3.0.4
Due in Version 3.1.0
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

cf  FS#3241 
in pacman 2.9.8, makepkg --syncdeps install missing depends with: "pacman $PACMAN_OPTS -D $deplist"

this "-D" option seems to have disapeared in pacman3.

Now all depends are installed with REASON="Explicitly installed" instead of "Installed as dependency" and so, they could not be removed by pacman -Rcs.

This task depends upon

Closed by  Dan McGee (toofishes)
Monday, 16 July 2007, 02:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in pacman 3.1. If anyone wants to backport it to CVS, go for it, but I don't plan on doing it.
Comment by Dan McGee (toofishes) - Wednesday, 30 May 2007, 18:55 GMT
This seemed like a hack to us, and I personally find undocumented options (like this one) a terrible idea. Perhaps it could be reimplemented with the standard op flags?
pacman -U --asdeps $deplist

Patches welcome, it shouldn't be too hard to find where we took this out by digging through some RCS history.
Comment by Xavier (shining) - Friday, 01 June 2007, 22:42 GMT
Maybe it's a little hackish, but I see the usage :)
Seeing the Revision 1.102 there : http://cvs.archlinux.org/cgi-bin/viewcvs.cgi/src/pacman/pacman.c?cvsroot=Pacman
where it was removed, it looks like it would be very easy to add it back.
Comment by Aaron Griffin (phrakture) - Monday, 04 June 2007, 19:35 GMT
Well it was removed because it was hackish and undocumented. I think it we add the _feature_ back in, we should do it correctly. I think I like Dan's suggestion, adding a op flag to be used with -U and -S. It gives us more functionality too.
Comment by Dan McGee (toofishes) - Sunday, 15 July 2007, 16:52 GMT
Here is my fix against GIT, currently in my working tree. Seems to work fine with the two pactests I added.
Comment by Dan McGee (toofishes) - Monday, 16 July 2007, 02:04 GMT

Loading...