Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7184 - glibc needs gzip

Attached to Project: Arch Linux
Opened by Julien MISCHKOWITZ (wain) - Thursday, 17 May 2007, 08:15 GMT
Last edited by Roman Kyrylych (Romashka) - Thursday, 17 May 2007, 19:57 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To No-one
Architecture All
Severity Very Low
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Please add gzip to depends in glibc package
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Thursday, 17 May 2007, 19:57 GMT
Reason for closing:  Not a bug
Comment by Jan de Groot (JGC) - Thursday, 17 May 2007, 09:07 GMT
Any reason for this?
Comment by Roman Kyrylych (Romashka) - Thursday, 17 May 2007, 11:19 GMT
and then add glibc dependency to gzip package :P (kidding)
Comment by Julien MISCHKOWITZ (wain) - Thursday, 17 May 2007, 19:48 GMT
Because locale-gen needs gzip to generate locales.
Comment by Roman Kyrylych (Romashka) - Thursday, 17 May 2007, 19:56 GMT
Do you want circular dependency???

[roman@home ~]$ pacman -Qi gzip | grep Depends
Depends On : glibc bash

Now what pacman should do if we add gzip as glibc dependency?

Also, locale-gen is not _required_ to run glibc, at least with English language.
Besides, gzip is part of base, so if user decides to not install it - he must know what he is doing. ;-)

Loading...