Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71788 - [mkinitcpio] Custom keymaps aren't supported in the `sd-vconsole` build hook

Attached to Project: Arch Linux
Opened by simonzack (simonzack) - Tuesday, 10 August 2021, 10:10 GMT
Last edited by Giancarlo Razzolini (grazzolini) - Thursday, 02 September 2021, 00:56 GMT
Task Type Feature Request
Category Packages: Core
Status Closed
Assigned To Giancarlo Razzolini (grazzolini)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Custom keymaps aren't supported in the `/usr/lib/initcpio/install/sd-vconsole` build hook.

I've described the issue below, and attached the files to reproduce for convenience.

- `vconsole.conf`. My console config.
- `mkinitcpio.conf`. My initcpio config.
- `sd-vconsole-custom`. My custom hook to temporarily solve this issue, pending an official fix.
- `sd-vconsole`. My patched hook to fix this issue.

Additional info:
* package version(s) mkinitcpio 30-2

Steps to reproduce:

Custom keymap `/etc/vconsole.conf` per https://wiki.archlinux.org/title/Linux_console/Keyboard_configuration#Persistent_configuration:

```
KEYMAP=/usr/local/share/kbd/keymaps/personal
FONT=Lat2-Terminus16
```

Include the `sd-vconsole` build hook in `/etc/mkinitcpio.conf`. My hooks are:

```
HOOKS=(base systemd autodetect modconf block keyboard sd-vconsole sd-vconsole-custom fsck filesystems)
```

Run:

```
$ sudo mkinitcpio --allpresets
$ lsinitcpio /boot/initramfs-linux.img
```

The `/usr/local/share/kbd/keymaps/personal.map` file will be missing there, including any of it's include files.
This task depends upon

Closed by  Giancarlo Razzolini (grazzolini)
Thursday, 02 September 2021, 00:56 GMT
Reason for closing:  Won't implement
Comment by Giancarlo Razzolini (grazzolini) - Thursday, 02 September 2021, 00:56 GMT
To be quite honest, I don't think mkinitcpio should support loading keymaps from /usr/local. I've checked other initramfs generators and they also don't support this. I suggest you add this to /usr/share/kbd/keymaps and it won't be touched by pacman, since it's not part of any package.

Loading...