Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7171 - firefox 2.0.0.3-2 has problems with SSL sites

Attached to Project: Arch Linux
Opened by Jason Carr (jason2) - Tuesday, 15 May 2007, 18:13 GMT
Last edited by Roman Kyrylych (Romashka) - Friday, 18 May 2007, 15:08 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture All
Severity High
Priority Normal
Reported Version 2007.05 Duke
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

firefox 2.0.0.3-2 has problems loading websites that use SSL. I downgraded to 2.0.0.3-1 and all sites worked properly. I tried disabling all add-ons and creating a new profile, neither helped. I tried a multitude of sites as well including internal sites and gmail.com. All would fail.
This task depends upon

Closed by  Roman Kyrylych (Romashka)
Friday, 18 May 2007, 15:08 GMT
Reason for closing:  Fixed
Comment by XazZ (XazZ) - Tuesday, 15 May 2007, 20:08 GMT
Hi...

I've also noticed problems with firefox and ssl sites..
I got apache running on my box here... and I've enabled ssl there...
I've tested some ssl-sites with swiftfox (you can get it from aur)... and they worked like a charm...
Comment by Alexander Baldeck (kth5) - Tuesday, 15 May 2007, 21:01 GMT
i cannot reproduce the problem. just visited a couple of sites an they work. can you provide some links please?
Comment by XazZ (XazZ) - Tuesday, 15 May 2007, 21:18 GMT
gmail is one of the sites...
Another is my localhost
ebay also didn't let me in (I tried it a few times, after a while it worked again)

gmail hangs at a white site and ebay shows a white page too...
Comment by XazZ (XazZ) - Wednesday, 16 May 2007, 10:39 GMT
It's me again...
Today I got the same problem as yesterday... - ssl-sites won't load..
I've made a screenshot to show what I mean...
Site nr. 1 is ebay... it tries to load and load and so on...
Site nr. 2 and 3 are from awstats - running at my apache...
As you can see the URL without ssl-encryption works, but the ssl-encrypted one doesn't

I've made a second screenshot...
It shows the browser links...
In links are all ssl-encrypted URLs working..

I hope this helped..
Comment by Jason Carr (jason2) - Wednesday, 16 May 2007, 15:39 GMT
I'm thinking but 7168 has to do with this...

http://bugs.archlinux.org/task/7168
Comment by XazZ (XazZ) - Wednesday, 16 May 2007, 19:52 GMT
It's me again...
I looked at this bug-report http://bugs.archlinux.org/task/7168 (as jason2 said...)
I've modified the patch as suggested in that bug report...
Now it seems that everything is working fine (I could only test ~1 hour... - but I couldn't find any problem yet)

I've attached the PKGBUILD and all necessary files... - You can create you own package from this with makepkg

XazZ
Comment by Ramses de Norre (Ramses_de_Norre) - Thursday, 17 May 2007, 22:11 GMT
I'm experiencing a problem that might be related, when I log in on the secured web-portal of my university, everything works at first, but when I try to download a document (always pdf's), firefox can't load it and just sits there with the loading icon. All other sites work fine but that particular web-portal no longer does. Only way to get in again is to reinstall firefox (pacman -U).
I'm not sure if it's the same bug though.
Comment by Alexander Baldeck (kth5) - Friday, 18 May 2007, 00:13 GMT
please try -3 again. i reverted the powertop patch, sorry for being a little rash on including it.
Comment by Morgan LEFIEUX (Comete) - Friday, 18 May 2007, 08:46 GMT
I have the same problem with SSL sites when using firefox 2.0.0.3-2. So i downgraded to 2.0.0.3-1 too.
But one question: Why firefox 2.0.0.3-2 package is still in current ??? Are you waiting for the next release to correct the bug ?
What's the problem with Arch Linux actually ? it seems that the packages are going more and more unstable... I can't use this system in production anymore, to o much bad surprises... wake up guys ! or you will loose your users...
Comment by Roman Kyrylych (Romashka) - Friday, 18 May 2007, 11:19 GMT
Comete: that's because mirrors cannot update instantly.
Didn't you see Alexander's comment above?
firefox 2.0.0.3-3 was uploaded to Current 11 hours before your comment ;-)
Comment by Morgan LEFIEUX (Comete) - Friday, 18 May 2007, 11:53 GMT
I have the same problem with SSL sites when using firefox 2.0.0.3-2. So i downgraded to 2.0.0.3-1 too.
But one question: Why firefox 2.0.0.3-2 package is still in current ??? Are you waiting for the next release to correct the bug ?
What's the problem with Arch Linux actually ? it seems that the packages are going more and more unstable... I can't use this system in production anymore, to o much bad surprises... wake up guys ! or you will loose your users...
Comment by Roman Kyrylych (Romashka) - Friday, 18 May 2007, 12:02 GMT
why double post?
Comment by Morgan LEFIEUX (Comete) - Friday, 18 May 2007, 12:36 GMT
sorry just a bad refresh...
Comment by Ramses de Norre (Ramses_de_Norre) - Friday, 18 May 2007, 14:51 GMT
After a first test, the bug I was experiencing seems to be solved with the 2.0.0.3-3 package, thanks.
Comment by XazZ (XazZ) - Friday, 18 May 2007, 15:06 GMT
Yes, it seems to be solved :)
I've tested since 14 pm (CEST) an until now I couldn't find any bugs...
Big thanks for updating it so fast

XazZ

Loading...