Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71709 - [pulseaudio] No audio until manual alsactl restore

Attached to Project: Arch Linux
Opened by Jakub Gołębicki (ashton) - Monday, 02 August 2021, 20:26 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 22 June 2022, 18:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
David Runge (dvzrv)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:


Additional info:
* package version(s)
extra/pulseaudio 15.0-1
(possibly related)
extra/pulseaudio-bluetooth 15.0-1
extra/libpulse 15.0-1
extra/alsa-card-profiles 1:0.3.32-2

* config and/or log files etc.
config files attached

systemctl status alsa-restore ✘ 99
● alsa-restore.service - Save/Restore Sound Card State
Loaded: loaded (/usr/lib/systemd/system/alsa-restore.service; static)
Active: active (exited) since Fri 2021-07-30 11:18:50 CEST; 12min ago
Process: 463 ExecStart=/usr/bin/alsactl restore (code=exited, status=0/SUCCESS)
Main PID: 463 (code=exited, status=0/SUCCESS)
CPU: 3ms

lip 30 11:18:50 uroboros systemd[1]: Starting Save/Restore Sound Card State...
lip 30 11:18:50 uroboros alsactl[463]: alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HDA NVidia at >
lip 30 11:18:50 uroboros alsactl[463]: alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configu>
lip 30 11:18:50 uroboros systemd[1]: Finished Save/Restore Sound Card State.

Steps to reproduce:
No sound on reboot. Changing settings in alsamixer has no effect.
Sound only appears after manually entering alsactl restore either by user or root.
alsa-restore.service status shows it's been run on boot.
errors in status show up also on alsactl restore, and aside from different line numbers show up in downgraded version, likely unrelated.
After asking on forum it was suggested to downgrade pulseaudio/libpulse and alsa-card-profiles which solved the issue.
I also had to downgrade pulseaudio-bluetooth, as such i'm also mentioning it here.
Problem started before i upgraded alsa-card-profiles, right after updating pulse among many things. so I believe it might be not related.

link to topic with more info about some strange behaviour like wrong outputs.
https://bbs.archlinux.org/viewtopic.php?id=268406

current
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 22 June 2022, 18:45 GMT
Reason for closing:  Works for me
Comment by Jakub Gołębicki (ashton) - Wednesday, 03 November 2021, 02:04 GMT
There's been some more details about going around it and pulse being most likely culprit:

https://bbs.archlinux.org/viewtopic.php?pid=2000209#p2000209

Seems like Headphone Out disables audio, Line out enables it, following which there seems to be no reaction to changes in alsa output.

Sound card has both line out and headphone out, in my case it was tested with hw connected to Headphone Output.
Comment by David Runge (dvzrv) - Friday, 10 June 2022, 10:00 GMT
Is this still an issue with pulseaudio 16.0?
Comment by Jakub Gołębicki (ashton) - Wednesday, 22 June 2022, 13:19 GMT
Hey sorry for late reply, was busy recently.
Can't tell I've gave up on pulse and switched to pipe wire some time ago.
Given nobody is having those issues I'd assume it's fixed.
Comment by Jan Alexander Steffens (heftig) - Wednesday, 22 June 2022, 18:45 GMT
I suspect this is/was a bug in the card profiles (in /usr/share/alsa-card-profile/mixer/ for PipeWire, or in /usr/share/pulseaudio/alsa-mixer/ for PulseAudio).



As an aside, generally (independent of the sound service you use), I would recommend doing

touch /etc/alsa/state-daemon.conf

which causes ALSA to start a daemon at boot that periodically saves device state instead of saving once at shutdown, which allows keeping the state of any devices that get hot-unplugged.

Loading...