Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71690 - [gitea] commit search fails

Attached to Project: Community Packages
Opened by George Rawlinson (rawlinsong) - Monday, 02 August 2021, 00:34 GMT
Last edited by Bruno Pagani (ArchangeGabriel) - Monday, 11 October 2021, 23:13 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bruno Pagani (ArchangeGabriel)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description: When searching through commits on the web interface, any search fails with a 500.

This seems to be specific to Arch Linux & git/pcre2 according to this bug report: https://github.com/go-gitea/gitea/issues/10840

The report has no resolution as it was prematurely closed. It does include log output which closely mirror mine.

Mär 26 16:47:12 domain.tld hostname[881]: 2020/03/26 16:47:12 ...uters/repo/commit.go:133:SearchCommits() [E] SearchCommits: exit status 128 - fatal: Couldn't JIT the PCRE2 pattern 'example search', got '-48'

Additional info:
* gitea 1.14.5-1
* git 2.32.0-1
* pcre2 10.37-1

Steps to reproduce:

Visit any repository on an instance hosted on Arch Linux, select the "commits" link at the top of the page, and attempt to perform a search.
This task depends upon

Closed by  Bruno Pagani (ArchangeGabriel)
Monday, 11 October 2021, 23:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  Disabled MemoryDenyWriteExecute in 1.15.4-1 since it does indeed block any JIT engine, while one is required here.
Comment by Andrew (gman) - Thursday, 16 September 2021, 11:48 GMT
Commenting out MemoryDenyWriteExecute=true in gitea.service may fix the problem.

Loading...