Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71685 - x11vnc closes session unexpectedly

Attached to Project: Community Packages
Opened by Stephan von Krawczynski (skraw) - Sunday, 01 August 2021, 19:46 GMT
Last edited by Morten Linderud (Foxboron) - Friday, 06 August 2021, 09:02 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Daniel Bermond (Bermond)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

It is not easy to describe. Since few kernel-versions x11vnc seems to close the vnc sessions within several minutes without reproducable reason.
I tried realvnc viewer and tigervnc viewer, all the same problem. So it seems it is a server side issue, not related to the viewers.



Additional info:
* package version(s)

Latest: 1:0.9.16-4

* config and/or log files etc.

X11vnx is started with:

noxrecord
ncache_cr
cursor arrow
xkb
rfbauth <USERDIR>/.vnc/passwd
repeat
noipv6
inetd
display :0
o /var/log/x11vnc.log
env FD_XDM=1
env XAUTHORITY=/var/lib/xdm/authdir/authfiles/A:0-6AS5kk

These are the last log lines:

01/08/2021 21:37:35 Using compression level 2 for client A.B.C.D
01/08/2021 21:37:35 Using image quality level 8 for client A.B.C.D
01/08/2021 21:37:35 Using JPEG subsampling 0, Q92 for client A.B.C.D
01/08/2021 21:37:35 Switching from tight to tight Encoding for client A.B.C.D
caught XIO error:
01/08/2021 21:37:46 deleted 60 tile_row polling images.
tail: /var/log/x11vnc.log: Datei abgeschnitten

And then x11vnc restarts ...


* link to upstream bug report, if any

Steps to reproduce:

Start x11vnc like above and connect with some viewer. It should take few minutes until the session closes unexpectedly
This task depends upon

Comment by Daniel Bermond (Bermond) - Friday, 06 August 2021, 15:50 GMT
Please try to use the '-noxdamage' option.
Comment by Stephan von Krawczynski (skraw) - Saturday, 07 August 2021, 09:28 GMT
I found the noxdamage flag circumvents the problem. But nevertheless there is a problem. I used this same setup with continuous updates for years without this flag and it worked flawlessly. But one of the recent updates the last 2 months brought up this documented problem, and I cannot find out which update it was.
Comment by Daniel Bermond (Bermond) - Monday, 09 August 2021, 19:45 GMT
This is a know upstream issue[1][2][3]. The X Damage extension is known to cause problems, and users having 'caught XIO error' messages should disable it with '-noxdamage'.

I have added an entry to the Troubleshooting section of the x11vnc Wiki article[4] describing this known issue and the instruction on how to fix it.

[1] https://github.com/LibVNC/x11vnc/issues/154
[2] https://github.com/LibVNC/x11vnc/issues/147
[3] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815909
[4] https://wiki.archlinux.org/title/X11vnc#Session_closes_unexpectedly

Loading...