Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71667 - add python-evdev as optional dependency for libevdev

Attached to Project: Arch Linux
Opened by Caleb Cushing (xenoterracide) - Friday, 30 July 2021, 16:43 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 31 July 2021, 20:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

this would have been useful for debugging a problem I'm experiencing with fprintd. It generally isn't required, but would be good to suggest it. see https://gitlab.freedesktop.org/libinput/libinput/-/issues/641#note_1012883 the top part of the comment, and maybe my comment above it.
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 31 July 2021, 20:45 GMT
Reason for closing:  Not a bug
Comment by Caleb Cushing (xenoterracide) - Saturday, 31 July 2021, 15:30 GMT
  • Field changed: Percent Complete (100% → 0%)
a piece of a command in libinput relies on python-evdev. let me quote that other ticket for you

THIS is the eror

```
Traceback (most recent call last):
File "/usr/lib/libinput/libinput-analyze-per-slot-delta", line 36, in <module>
import libevdev
ModuleNotFoundError: No module named 'libevdev'

```

from the libinput developer
> satrmb
satrmb @satrmb ยท 2 hours ago
Developer

> libinput analyze per-slot-delta is a Python tool, so you would have needed to sudo pacman -S python-libevdev too. No big problem, it's just a different (usually more convenient) view of the recording, so I simply did it over here.

so while you are correct, they are not the same, the app will error out without it when you invoke that command. Please reconsider.
Comment by Antonio Rojas (arojas) - Saturday, 31 July 2021, 15:32 GMT
> a piece of a command in libinput relies on python-evdev

which is why libinput *ALREADY* has an optdepend on python-evdev. Can you explain why we should add it to *libevdev*?
Comment by Caleb Cushing (xenoterracide) - Saturday, 31 July 2021, 20:40 GMT
sorry, now that you've said it has optdepends, I thought a package reinstall would prompt me for those, it does not. Next time I'll look at the PKGBUILD before filing this kind of bug. My bad.

Loading...