Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71653 - [pango] needs rebuild ?

Attached to Project: Arch Linux
Opened by Michel (xantares) - Thursday, 29 July 2021, 14:15 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 14 October 2021, 21:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm getting a segfault with pango 1.48.7 from an R script

I tried rebuilding it with debug symbols but it wasnt crashing anymore.

If I just rebuild it with no changes to PKGBUILD the segfault goes away

To reproduce:

sudo pacman -S r
R --no-save --silent < graph.r

Here is the segfault:

#0 0x00007ffff4044494 in pango_shape_with_flags () at /usr/lib/libpango-1.0.so.0
#1 0x00007ffff4035181 in () at /usr/lib/libpango-1.0.so.0
#2 0x00007ffff40362ed in () at /usr/lib/libpango-1.0.so.0
#3 0x00007ffff403bc0f in () at /usr/lib/libpango-1.0.so.0
#4 0x00007ffff402fe49 in pango_layout_get_line () at /usr/lib/libpango-1.0.so.0
#5 0x00007ffff2cf1485 in () at /usr/lib64/R/library/grDevices/libs//cairo.so
#6 0x00007ffff7c0c9d9 in GEStrWidth () at /usr/lib/R/lib/libR.so
#7 0x00007ffff7c0d581 in GEText () at /usr/lib/R/lib/libR.so
#8 0x00007ffff451eff7 in () at /usr/lib/R/library/graphics/libs/graphics.so
#9 0x00007ffff453d9e0 in () at /usr/lib/R/library/graphics/libs/graphics.so
#10 0x00007ffff7bf9009 in () at /usr/lib/R/lib/libR.so
#11 0x00007ffff7bfb473 in () at /usr/lib/R/lib/libR.so
#12 0x00007ffff7c43858 in () at /usr/lib/R/lib/libR.so
#13 0x00007ffff7c52250 in Rf_eval () at /usr/lib/R/lib/libR.so
#14 0x00007ffff7c53e60 in () at /usr/lib/R/lib/libR.so
#15 0x00007ffff7c54ccf in Rf_applyClosure () at /usr/lib/R/lib/libR.so
#16 0x00007ffff7c42022 in () at /usr/lib/R/lib/libR.so
#17 0x00007ffff7c52250 in Rf_eval () at /usr/lib/R/lib/libR.so
#18 0x00007ffff7c53e60 in () at /usr/lib/R/lib/libR.so
#19 0x00007ffff7c54ccf in Rf_applyClosure () at /usr/lib/R/lib/libR.so
#20 0x00007ffff7c42022 in () at /usr/lib/R/lib/libR.so
#21 0x00007ffff7c52250 in Rf_eval () at /usr/lib/R/lib/libR.so
#22 0x00007ffff7c53e60 in () at /usr/lib/R/lib/libR.so
#23 0x00007ffff7c54ccf in Rf_applyClosure () at /usr/lib/R/lib/libR.so
#24 0x00007ffff7c98d88 in () at /usr/lib/R/lib/libR.so
#25 0x00007ffff7c99188 in () at /usr/lib/R/lib/libR.so
#26 0x00007ffff7c995cc in () at /usr/lib/R/lib/libR.so
#27 0x00007ffff7c342e8 in () at /usr/lib/R/lib/libR.so
#28 0x00007ffff7c52250 in Rf_eval () at /usr/lib/R/lib/libR.so
#29 0x00007ffff7c53e60 in () at /usr/lib/R/lib/libR.so
#30 0x00007ffff7c54ccf in Rf_applyClosure () at /usr/lib/R/lib/libR.so
#31 0x00007ffff7c5237e in Rf_eval () at /usr/lib/R/lib/libR.so
#32 0x00007ffff7c87196 in Rf_ReplIteration () at /usr/lib/R/lib/libR.so
#33 0x00007ffff7c87521 in () at /usr/lib/R/lib/libR.so
#34 0x00007ffff7c875d9 in run_Rmainloop () at /usr/lib/R/lib/libR.so
#35 0x000055555555503d in main ()
   graph.r (2.5 KiB)
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 14 October 2021, 21:50 GMT
Reason for closing:  Won't fix
Additional comments about closing:  2021-09-19: A task closure has been requested. Reason for request: Fixed upstream. If the issue is related to the presence of `ttf-dejavu`, it is out of the scope of this report. You should open a proper one.
Comment by Jan Alexander Steffens (heftig) - Sunday, 01 August 2021, 17:09 GMT
Rebuilding pango here did not result in any changes to the libraries.
Comment by Antonio Rojas (arojas) - Sunday, 01 August 2021, 21:34 GMT
I can't reproduce the crash
Comment by Michel (xantares) - Monday, 02 August 2021, 09:23 GMT
it was more subtle than I thought: it crashes if ttf-dejavu is not installed

as rebuilding pango requires ttf-dejavu I thought it just needed a bump, and you probably had ttf-dejavu already installed on your system that's why you did not reproduce

do you think pango should pull ttf-dejavu ?

Loading...