Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71614 - [util-linux-libs] Upgrading to 2.37.1-1 breaks mount.davfs

Attached to Project: Arch Linux
Opened by Stephan Windmüller (windy) - Sunday, 25 July 2021, 16:00 GMT
Last edited by Christian Hesse (eworm) - Friday, 07 January 2022, 21:13 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
After upgrading util-linux-libs to 2.37.1-1, mount.davfs stopped working. It quits with this error message:

/usr/bin/mount.davfs: can't read group data base

Downgrading to 2.37-3 fixed the problem and mounting DAV volumes is possible again.
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 07 January 2022, 21:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  util-linux 2.37.2-1
Comment by Stephan Windmüller (windy) - Monday, 26 July 2021, 19:55 GMT
Upstream bugreport for davfs2 created: https://savannah.nongnu.org/support/index.php?110519
Comment by loqs (loqs) - Thursday, 29 July 2021, 11:47 GMT Comment by Stephan Windmüller (windy) - Thursday, 29 July 2021, 20:00 GMT
This has been fixed in the master branch of util-linux by now: https://github.com/karelzak/util-linux/issues/1398
Comment by Mikhail (whitearchey) - Thursday, 14 October 2021, 21:59 GMT
  • Field changed: Percent Complete (100% → 0%)
/usr/bin/mount.davfs: user username must be member of group network

Need to include two more commits
Comment by Christian Hesse (eworm) - Friday, 15 October 2021, 21:28 GMT
We have 2.37.2-1 already... Is it fixed there?
If not: What's missing?
Comment by Mikhail (whitearchey) - Sunday, 31 October 2021, 14:58 GMT Comment by Christian Hesse (eworm) - Monday, 01 November 2021, 19:33 GMT
So it is fixed? Yes or no?
Comment by Stephan Windmüller (windy) - Monday, 01 November 2021, 19:52 GMT
For me, who filed the original bugreport, the problem is fixed.

Loading...