Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71612 - Issues with firefox, chrome, skype and spotify after upgrading to kernel 5.13.4.arch2-1

Attached to Project: Arch Linux
Opened by Alessandro Campagni (sciamp) - Sunday, 25 July 2021, 15:26 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 27 July 2021, 20:34 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description:

I had some issues with firefox after upgrading today, but it turned out it wasn't a firefox issue.

I'm running qtile and the firefox window was repeatedly flashing from half screen to full screen, it was also impossible to navigate anywhere because Ctrl+L was focusing the address bar but no characters were appearing while entering addresses.

I fired up google chrome to start figuring out what was happening and I ended up with the same issues (chrome was actually slightly better because I was able to close tabs).

I started worrying it was not a firefox problem: I had some issues with spotify (flickering) and skype (window constantly resizing).

I then downgraded the kernel to a previous version I had in the pacman cache (linux-5.12.14.arch1-1-x86_64.pkg.tar.zst) rebooted and everything started working fine.

I'm on an Intel core i5 11700K and using the integrated GPU

Additional info:
* package version(s)
upgraded firefox-developer-edition (91.0b3-1 -> 91.0b6-1)
upgraded linux (5.12.15.arch1-1 -> 5.13.4.arch2-1)
upgraded linux-firmware (20210511.7685cf4-1 -> 20210716.b7c134f-1)
upgraded google-chrome (91.0.4472.164-1 -> 92.0.4515.107-1)
skypeforlinux-stable-bin (8.73.0.129-1 -> 8.74.0.152-1)

Steps to reproduce:
1) upgrade to 5.13.4.arch2-1 kernel
2) open firefox
3) hit Ctrl+K, Ctrl+L
4) try to write something in the address bar

Please let me know if you need more information :)

Thanks
This task depends upon

2021-09-05: A task closure has been requested. Reason for request: (as detailed in comment [0]) this was happening because I was using a non recommended driver [0] https://bugs.archlinux.org/task/71612#comment202069
Comment by Alessandro Campagni (sciamp) - Saturday, 31 July 2021, 14:57 GMT
Hi, I'm not sure if it helps but I just tried updating linux to 5.13.6.arch1-1 and still experiencing the same issues. As the last time rolling back to 5.12.14 did the trick :)

Thanks,
Alessandro
Comment by Leo Zhang (liftm) - Wednesday, 04 August 2021, 18:12 GMT
I'm seeing the same thing here as well. I think I've encountered this before, I suspect it's a graphics driver issue. I'll try downgrading later today.
Comment by Alessandro Campagni (sciamp) - Sunday, 05 September 2021, 18:21 GMT
Hi, I tried updating to linux 5.13.13 and the issue was still there.
But this time I realized I've been using the wrong drivers the whole time. As suggested in the Arch Wiki [0] I removed the xf86-video-intel package and everything started to work like a charm.

For comparison I was getting something like 35 FPS and now I got 60 FPS on glxgears

Thanks and sorry for wasting your time, I'm marking this as closed since I guess I was being the bug myself :)

[0] https://wiki.archlinux.org/title/intel_graphics#Installation

Loading...