Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#71608 - Pacman only search for a package on first repository on the list

Attached to Project: Pacman
Opened by Guillermo (gambar) - Sunday, 25 July 2021, 01:16 GMT
Last edited by Allan McRae (Allan) - Saturday, 04 September 2021, 02:29 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version 6.0.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Summary and Info:
After update to version 6.0.0 (Pacman v6.0.0 - libalpm v13.0.0), when a packge is missing from firs repo on the list of repositories, it do not check on the next repository (i have only 2 repositories) and inmediatly stops update/install proccess.

Steps to Reproduce:

For a very particular reason i use 2 repositories, when fails to download some file from the first one i have to coment the repository line on the configuration file to download from next one, pacman do not continue automatyically like before the update.
This task depends upon

Closed by  Allan McRae (Allan)
Saturday, 04 September 2021, 02:29 GMT
Reason for closing:  No response
Additional comments about closing:  Works for me.
Comment by morganamilo (morganamilo) - Sunday, 25 July 2021, 01:23 GMT
You need more detail, I don't really understand what you mean.

Do you mean a download fails for a package from repo a and you want it to then try download from repo b?
Comment by Guillermo (gambar) - Sunday, 25 July 2021, 01:55 GMT
I have 2 repositories enabled on "/etc/pacman.d/mirrorlist" file, normally when pacman can't download a package from first repo on the list on mirrorlist file, pacman try with the next enabled repo on mirrorlist file. After update to version 6.0.0 the behavior of pacman is to stop the install or update task when it fail to download some file for first time, pacman do not search for that file on next repository on the list of enabled repositories on "mirrorlist".
Comment by Allan McRae (Allan) - Sunday, 25 July 2021, 05:39 GMT
Can you post the pacman output from an example of what you are trying to do with the "--debug" flag?
Comment by Eli Schwartz (eschwartz) - Wednesday, 28 July 2021, 05:04 GMT
So I don't think this has anything whatsoever to do with "repos". The list of repos is:

core
extra
community

(plus extras)

> I have 2 repositories enabled on "/etc/pacman.d/mirrorlist"

You have two mirrors enabled in that file. Mirrors, not repositories.

pacman should and does try the next enabled mirror when it can't download a package from the first mirror.

...

I agree that without --debug output we can't really understand what you want here.
Comment by Guillermo (gambar) - Sunday, 01 August 2021, 18:11 GMT
"You have two mirrors enabled in that file. Mirrors, not repositories."----> Ok, main bad.

"pacman should and does try the next enabled mirror when it can't download a package from the first mirror."--->pacman DON'T TRY THE NEXT ENABLED mirror when it can't download a package from the first mirror.

That is the thing, fails and it don't try the next enabled mirror.



Comment by morganamilo (morganamilo) - Sunday, 01 August 2021, 19:07 GMT
Please provide the output with --debug as asked or there's nothing we can do.

Loading...