Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71600 - [catfish] fails to launch

Attached to Project: Community Packages
Opened by Richard Benson (richardbenson91477) - Friday, 23 July 2021, 23:33 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 12 August 2021, 09:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Felix Yan (felixonmars)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description: fails to launch

Additional info:
* catfish 4.16.1-1
* python 3.9.6-1
* can be worked around by editing /usr/lib/python3.9/site-packages/catfish_lib/catfishconfig.py line 30 to say:
__catfish_data_directory__ = "/usr/share/catfish'
(which is obviously not ideal)

Steps to reproduce: try to run 'catfish'
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 12 August 2021, 09:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  catfish 4.16.2
Comment by nordine-philippe abdessemed (npa) - Saturday, 24 July 2021, 00:42 GMT
Same problem.
Comment by Trit' (trit) - Saturday, 24 July 2021, 08:39 GMT
Same here after updating to 4.16.1, with traceback:

Traceback (most recent call last):
File "/usr/bin/catfish", line 44, in <module>
catfish.main()
File "/usr/lib/python3.9/site-packages/catfish/__init__.py", line 78, in main
window = CatfishWindow.CatfishWindow()
File "/usr/lib/python3.9/site-packages/catfish_lib/Window.py", line 173, in __new__
builder = get_builder(__builder__['ui_file'])
File "/usr/lib/python3.9/site-packages/catfish_lib/helpers.py", line 87, in get_builder
ui_filename = get_data_file('ui', '%s.ui' % (builder_file_name,))
File "/usr/lib/python3.9/site-packages/catfish_lib/catfishconfig.py", line 50, in get_data_file
return os.path.join(get_data_path(), *path_segments)
File "/usr/lib/python3.9/site-packages/catfish_lib/catfishconfig.py", line 67, in get_data_path
raise project_path_not_found
catfish_lib.catfishconfig.project_path_not_found

Editing "/usr/lib/python3.9/site-packages/catfish_lib/catfishconfig.py" as said in the bug report works for me (after having copied the original version elsewhere, of course). I guess it was just caused by a bad setting in this file.
Comment by loqs (loqs) - Saturday, 24 July 2021, 10:05 GMT Comment by Renato Candido (renatocan) - Saturday, 24 July 2021, 14:51 GMT
Same problem.
Comment by gavsiu (gavsiu) - Sunday, 25 July 2021, 18:33 GMT
Same. I was able to downgrade back to 4.16.0-4 to use it.
Comment by Ammako (Ammako) - Monday, 26 July 2021, 01:42 GMT
Upstream bug?

> If Arch is not responsible for a bug, the problem will not be solved by reporting the bug to Arch developers.

Keep tabs on the Xfce bug report and make sure to flag the package out of date once Xfce devs fix it and release a new version, so the fixed version can be available as soon as possible.
Comment by Angelino Desmet (CynicusRex) - Wednesday, 28 July 2021, 06:21 GMT
Same problem. For the moment I'm using the catfish-devel build from AUR instead: yay -S catfish-devel
Comment by Erik Wesselius (zilverling) - Wednesday, 28 July 2021, 09:33 GMT
Exactly the same issue. For the time being I downgraded to catfish 4.16.0-4.

Loading...