Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71582 - [digikam]: crashing after mariadb update 10.5.11 -> 10.6.3

Attached to Project: Arch Linux
Opened by Jürgen Blumenschein (jblume) - Thursday, 22 July 2021, 13:07 GMT
Last edited by Antonio Rojas (arojas) - Saturday, 14 August 2021, 08:15 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
digikam crashes when moving cursor over the last imported pictures, older pictures don't
error appers after pacman Syu with mariadb updated to 10.6.3
error disappears after downgrading to 10.5.11
"sudo systemctl restart mariadb.service && sudo mariadb-upgrade -u root -p" was done.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any
pacman -Qi digikam
Name : digikam
Version : 7.3.0-2
Beschreibung : An advanced digital photo management application
Architektur : x86_64
URL : https://www.digikam.org/
Lizenzen : GPL
Gruppen : Nichts
Stellt bereit : Nichts
Hängt ab von : lensfun opencv akonadi-contacts knotifyconfig libksane
kfilemetadata qtav marble-common threadweaver kcalendarcore
qt5-xmlpatterns imagemagick jasper glu perl-image-exiftool
Optionale Abhängigkeiten : hugin: panorama tool [Installiert]
qt5-imageformats: support for additional image formats (WEBP,
TIFF) [Installiert]
rawtherapee: RAW import [Installiert]
darktable: RAW import [Installiert]
perl: for digitaglinktree [Installiert]
Benötigt von : Nichts
Optional für : Nichts
In Konflikt mit : Nichts
Ersetzt : Nichts
Installationsgröße : 72,45 MiB
Packer : Antonio Rojas <arojas@archlinux.org>
Erstellt am : Mo 12 Jul 2021 18:24:08 CEST
Installiert am : Do 22 Jul 2021 11:44:27 CEST
Installationsgrund : Ausdrücklich installiert
Installations-Skript : Nein
Verifiziert durch : Signatur

Steps to reproduce:
error is reproduceable on all my three ArchLinux machines (1x Rhyzen, 2x Intel)
This task depends upon

Closed by  Antonio Rojas (arojas)
Saturday, 14 August 2021, 08:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  qt5-base 5.15.2+kde+r215-2
Comment by Jaron Kent-Dobias (pants) - Thursday, 22 July 2021, 15:28 GMT
I found the same problem. Rebuilding the digikam package (7.3.0-2) on a machine with the new mariadb libraries installed resolved the issue for me.
Comment by Antonio Rojas (arojas) - Thursday, 22 July 2021, 15:46 GMT
which kind of database? internal, external? have you run the migration after the update? Please post a backtrace and the terminal output.
Comment by Jürgen Blumenschein (jblume) - Thursday, 22 July 2021, 18:19 GMT
-` juergen@jbzenbook
.o+` -----------------
`ooo/ OS: Arch Linux x86_64
`+oooo: Host: UX410UQK 1.0
`+oooooo: Kernel: 5.13.4-arch1-1
-+oooooo+: Uptime: 9 mins
`/:-:++oooo+: Packages: 1980 (pacman)
`/++++/+++++++: Shell: bash 5.1.8
`/++++++++++++++: Resolution: 1920x1080
`/+++ooooooooooooo/` DE: Cinnamon 5.0.5
./ooosssso++osssssso+` WM: Mutter (Muffin)
.oossssso-````/ossssss+` WM Theme: Midnight-GrayNight (CBlack)
-osssssso. :ssssssso. Theme: Midnight-Gray [GTK2/3]
:osssssss/ osssso+++. Icons: breeze-dark [GTK2/3]
/ossssssss/ +ssssooo/- Terminal: konsole
`/ossssso+/:- -:/+osssso+- Terminal Font: Monospace 12
`+sso+:-` `.-/+oso: CPU: Intel i7-7500U (4) @ 3.500GHz
`++:. `-/+/ GPU: NVIDIA GeForce 940MX
.` `/ GPU: Intel HD Graphics 620
Memory: 1394MiB / 7819MiB





:: mariadb ist in IgnorePkg/IgnoreGroup. Trotzdem installieren? [J/n]
Warnung: mariadb-10.6.3-1 ist aktuell -- Reinstalliere
:: mariadb-libs ist in IgnorePkg/IgnoreGroup. Trotzdem installieren? [J/n]
Warnung: mariadb-libs-10.6.3-1 ist aktuell -- Reinstalliere
:: mariadb-clients ist in IgnorePkg/IgnoreGroup. Trotzdem installieren? [J/n]
Warnung: mariadb-clients-10.6.3-1 ist aktuell -- Reinstalliere
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (3) Alte Version Neue Version Netto-Veränderung

extra/mariadb 10.6.3-1 10.6.3-1 0,00 MiB
extra/mariadb-clients 10.6.3-1 10.6.3-1 0,00 MiB
extra/mariadb-libs 10.6.3-1 10.6.3-1 0,00 MiB

Gesamtgröße der installierten Pakete: 304,24 MiB
Größendifferenz der Aktualisierung: 0,00 MiB

:: Installation fortsetzen? [J/n]
(3/3) Schlüssel im Schlüsselbund werden geprüft [--------------------------------------------------------------------] 100%
(3/3) Paket-Integrität wird überprüft [--------------------------------------------------------------------] 100%
(3/3) Paket-Dateien werden geladen [--------------------------------------------------------------------] 100%
(3/3) Auf Dateikonflikte wird geprüft [--------------------------------------------------------------------] 100%
(3/3) Verfügbarer Festplattenspeicher wird ermittelt [--------------------------------------------------------------------] 100%
:: Paketänderungen werden verarbeitet …
(1/3) Reinstallation läuft mariadb-libs [--------------------------------------------------------------------] 100%
(2/3) Reinstallation läuft mariadb-clients [--------------------------------------------------------------------] 100%
(3/3) Reinstallation läuft mariadb [--------------------------------------------------------------------] 100%
:: Post-transaction-Hooks werden gestartet …
(1/5) Creating system user accounts...
(2/5) Reloading system manager configuration...
(3/5) Creating temporary files...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Refreshing PackageKit...
Enter password:
This installation of MariaDB is already upgraded to 10.6.3-MariaDB, use --force if you still need to run mysql_upgrade
QtAV 1.13.0(Jul 11 2019, 03:26:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
Speicherzugriffsfehler (Speicherabzug geschrieben)
Comment by Jürgen Blumenschein (jblume) - Thursday, 22 July 2021, 18:22 GMT
[juergen@jbzenbook ~]$ gdb digikam
GNU gdb (GDB) 10.2
Copyright (C) 2021 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Type "show copying" and "show warranty" for details.
This GDB was configured as "x86_64-pc-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<https://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.

For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from digikam...
(No debugging symbols found in digikam)
(gdb) run
Starting program: /usr/bin/digikam
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffd1b48640 (LWP 5303)]
[New Thread 0x7fffd0c8e640 (LWP 5304)]
[New Thread 0x7fffbffff640 (LWP 5305)]
[New Thread 0x7fffb7fff640 (LWP 5306)]
[New Thread 0x7fffbf7fe640 (LWP 5307)]
[New Thread 0x7fffbeffd640 (LWP 5308)]
[New Thread 0x7fffbe7fc640 (LWP 5309)]
[New Thread 0x7fffbdffb640 (LWP 5310)]
[New Thread 0x7fffbd7fa640 (LWP 5311)]
[New Thread 0x7fffbcff9640 (LWP 5312)]
[Thread 0x7fffbcff9640 (LWP 5312) exited]
[New Thread 0x7fffbcff9640 (LWP 5323)]
[New Thread 0x7fffb77fe640 (LWP 5324)]
[New Thread 0x7fffb6ffd640 (LWP 5325)]
[New Thread 0x7fffb67fc640 (LWP 5326)]
[New Thread 0x7fffb4946640 (LWP 5327)]
[New Thread 0x7fff87fff640 (LWP 5330)]
[Thread 0x7fff87fff640 (LWP 5330) exited]
[New Thread 0x7fff87fff640 (LWP 5331)]
[Detaching after fork from child process 5332]
[Detaching after fork from child process 5333]
[Detaching after fork from child process 5334]
[New Thread 0x7fff8732b640 (LWP 5337)]
[New Thread 0x7fff86b2a640 (LWP 5338)]
[New Thread 0x7fff86329640 (LWP 5339)]
[New Thread 0x7fff85b28640 (LWP 5340)]
[New Thread 0x7fff85327640 (LWP 5341)]
[New Thread 0x7fff84b26640 (LWP 5342)]
[New Thread 0x7fff67fff640 (LWP 5343)]
[New Thread 0x7fff677fe640 (LWP 5344)]
[New Thread 0x7fff66ffd640 (LWP 5345)]
[New Thread 0x7fff667fc640 (LWP 5346)]
[New Thread 0x7fff657fa640 (LWP 5348)]
[New Thread 0x7fff65ffb640 (LWP 5347)]
[New Thread 0x7fff64ff9640 (LWP 5349)]
[New Thread 0x7fff57fff640 (LWP 5350)]
[Thread 0x7fff57fff640 (LWP 5350) exited]
[New Thread 0x7fff57fff640 (LWP 5351)]
[Thread 0x7fff57fff640 (LWP 5351) exited]
[New Thread 0x7fff57fff640 (LWP 5352)]
[New Thread 0x7fff577fe640 (LWP 5353)]
QtAV 1.13.0(Jul 11 2019, 03:26:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
[New Thread 0x7fff56ffd640 (LWP 5354)]
[Detaching after vfork from child process 5355]
[Thread 0x7fff56ffd640 (LWP 5354) exited]
[New Thread 0x7fff56ffd640 (LWP 5356)]
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[New Thread 0x7fff567fc640 (LWP 5357)]
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[New Thread 0x7fff55ffb640 (LWP 5358)]
[New Thread 0x7fff557fa640 (LWP 5359)]
[Detaching after fork from child process 5360]
[New Thread 0x7fff54ff9640 (LWP 5361)]
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
[New Thread 0x7fff275ef640 (LWP 5378)]
[New Thread 0x7fff26dee640 (LWP 5381)]
[New Thread 0x7fff265ed640 (LWP 5382)]
[New Thread 0x7fff25dec640 (LWP 5384)]
[New Thread 0x7fff255eb640 (LWP 5385)]
[New Thread 0x7fff24dea640 (LWP 5386)]
[New Thread 0x7fff245e9640 (LWP 5387)]
[New Thread 0x7fff23de8640 (LWP 5390)]
[New Thread 0x7fff235e7640 (LWP 5391)]
[New Thread 0x7fff22de6640 (LWP 5393)]
[New Thread 0x7fff225e5640 (LWP 5394)]
[Thread 0x7fff26dee640 (LWP 5381) exited]
[Thread 0x7fff25dec640 (LWP 5384) exited]
[Thread 0x7fff23de8640 (LWP 5390) exited]
[Thread 0x7fff255eb640 (LWP 5385) exited]
[New Thread 0x7fff255eb640 (LWP 5396)]
[New Thread 0x7fff23de8640 (LWP 5397)]
[Thread 0x7fff22de6640 (LWP 5393) exited]
[New Thread 0x7fff22de6640 (LWP 5400)]
[Thread 0x7fff265ed640 (LWP 5382) exited]
[Thread 0x7fff24dea640 (LWP 5386) exited]
[Thread 0x7fff245e9640 (LWP 5387) exited]
[Thread 0x7fff235e7640 (LWP 5391) exited]
[Thread 0x7fff225e5640 (LWP 5394) exited]
[New Thread 0x7fff225e5640 (LWP 5403)]
[New Thread 0x7fff235e7640 (LWP 5404)]
[New Thread 0x7fff245e9640 (LWP 5405)]
--Type <RET> for more, q to quit, c to continue without paging--
Comment by Jürgen Blumenschein (jblume) - Thursday, 22 July 2021, 18:23 GMT
--Type <RET> for more, q to quit, c to continue without paging--c

Thread 1 "digikam" received signal SIGSEGV, Segmentation fault.
0x00007fffd01d9953 in mysql_get_socket () from /usr/lib/libmariadb.so.3
(gdb)
Comment by Jürgen Blumenschein (jblume) - Thursday, 22 July 2021, 18:33 GMT
[Database Settings]
Database Connectoptions=UNIX_SOCKET=/run/mysqld/mysqld.sock
Database Encrypted Password=XXXXXXXXXXXXXXXXXXXXXXXX==
Database Hostname=localhost
Database Name=digikam
Database Name Face=digikam_face
Database Name Similarity=digikam_similarity
Database Name Thumbnails=digikam_thumbs
Database Port=3306
Database Type=QMYSQL
Database Username=XXXXXXXXXXXX
Internal Database Server=false
Internal Database Server Mysql Admin Command=mysqladmin
Internal Database Server Mysql Init Command=
Internal Database Server Mysql Server Command=
Internal Database Server Path=
Comment by maderios (maderios) - Thursday, 22 July 2021, 19:47 GMT
I confirm this mariadb version package is buggy. After upgrading, i could not start digikam (external server)
'Failed to update the database schema from version 12 to 13 '
Console message:
digikamcoredb: 'Core database: cannot process schema initialization'
Issue was solved after downgrading to 10.5.11-1
Comment by maderios (maderios) - Friday, 23 July 2021, 10:21 GMT
Mariadb 10.6.3 is not "stable". Last stable was 10.5.12, not in Arch.
MariaDB "stable" 10.6.4 is coming soon.
https://jira.mariadb.org/secure/Dashboard.jspa
Comment by Antonio Rojas (arojas) - Friday, 23 July 2021, 10:28 GMT
> Mariadb 10.6.3 is not "stable"

Yes, it is

https://mariadb.com/kb/en/mariadb-1063-release-notes/
Comment by maderios (maderios) - Friday, 23 July 2021, 10:44 GMT
May be considered as "stable" but it causes many issues with Digikam. First issue for me as I explain it above. Second issue with Digikam and/or digikam-git: on an other computer, startup works but after that, it took hours to update db. I had to stop process. This issue doesn't exist no more after downgrading to mariadb 10.5.11.
Comment by Lee Donaghy (deadite66) - Friday, 23 July 2021, 12:47 GMT
for me mythbackend refused to start with 10.6.3, currently downgraded back to 10.5.11 until i can look to why.
Comment by Jürgen Blumenschein (jblume) - Saturday, 24 July 2021, 15:53 GMT
Hi Antonio,
do You think problem will be solves with the coming release 10.6.4? Or is it more a digikam problem?
Comment by Jürgen Blumenschein (jblume) - Sunday, 25 July 2021, 04:59 GMT
[Database Settings]
Database Connectoptions=UNIX_SOCKET=/run/mysqld/mysqld.sock
Database Encrypted Password=XXXXXXXXXXXXXXXXXXXXXXXX==
Database Hostname=localhost
Database Name=digikam
Database Name Face=digikam_face
Database Name Similarity=digikam_similarity
Database Name Thumbnails=digikam_thumbs
Database Port=3306
Database Type=QMYSQL
Database Username=XXXXXXXXXXXX
Internal Database Server=false
Internal Database Server Mysql Admin Command=mysqladmin
Internal Database Server Mysql Init Command=
Internal Database Server Mysql Server Command=
Internal Database Server Path=
Comment by Jürgen Blumenschein (jblume) - Sunday, 25 July 2021, 08:10 GMT
Hi Antonio,
do You think problem will be solves with the coming release 10.6.4? Or is it more a digikam problem?
Comment by Antonio Rojas (arojas) - Sunday, 25 July 2021, 09:22 GMT
can anybody reproduce this with a clean database?
Comment by maderios (maderios) - Sunday, 25 July 2021, 10:30 GMT
What do you mean by "clean"? An empty new db?
Before downgrading, I already tried to solve issue this way
mysqlcheck --all-databases -u root -p -c
mysqlcheck --all-databases -u root -p -r
mysqlcheck --all-databases -u root -p -o
mysqlcheck -A --auto-repair -f -o -u root -p
It said my db are clean but the bug was still there
Comment by Antonio Rojas (arojas) - Sunday, 25 July 2021, 10:41 GMT
Yes, starting with a new database
Comment by Lee Donaghy (deadite66) - Sunday, 25 July 2021, 10:57 GMT
at least in regards to the mythtv problem one of the developers thinks part of the issue is 'OFFSET is a reserved keyword' added 10.6.0.
causing a 'MySQL time zone support is missing' issue.
Comment by Antonio Rojas (arojas) - Sunday, 25 July 2021, 11:42 GMT
Let's please keep this focused on the digikam issue, unless there's proof that it's really the same problem.
To progress here I'll need step-by-step instructions to reproduce it starting from a clean configuration.
Comment by Jürgen Blumenschein (jblume) - Sunday, 25 July 2021, 12:55 GMT
Hi Antonio,
it's the same with a freshly created database and a new created user:

-` testuser@tuxedo
.o+` ---------------
`ooo/ OS: Arch
`+oooo: Kernel: 5.13.4-arch2-1
`+oooooo: Uptime: 4 hours, 20 mins
-+oooooo+: Packages: 1974 (pacman)
`/:-:++oooo+: Shell: bash 5.1.8
`/++++/+++++++: Resolution: 1920x1080
`/++++++++++++++: DE: Plasma 5.22.3
`/+++ooooooooooooo/` WM: KWin
./ooosssso++osssssso+` Theme: Breeze Light [Plasma], Arc-Dark [GTK2], Breeze [GTK3]
.oossssso-````/ossssss+` Icons: breeze [Plasma], breeze [GTK2/3]
-osssssso. :ssssssso. Terminal: sakura
:osssssss/ osssso+++. CPU: Intel i7-4702MQ (8) @ 3.200GHz
/ossssssss/ +ssssooo/- GPU: Intel 4th Gen Core Processor
`/ossssso+/:- -:/+osssso+- Memory: 1477MiB / 15909MiB (9%)
`+sso+:-` `.-/+oso:
`++:. `-/+/
.` `/


Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (3) Alte Version Neue Version Netto-Veränderung

extra/mariadb 10.5.11-1 10.6.3-1 1,02 MiB
extra/mariadb-clients 10.5.11-1 10.6.3-1 0,48 MiB
extra/mariadb-libs 10.5.11-1 10.6.3-1 0,04 MiB

Gesamtgröße der installierten Pakete: 304,24 MiB
Größendifferenz der Aktualisierung: 1,54 MiB

Schlüsselbund wird geprüft …
Paketintegrität wird geprüft …
Paket-Dateien werden geladen …
Auf Dateikonflikte wird geprüft …
Verfügbarer Festplattenspeicher wird ermittelt …
:: Paketänderungen werden verarbeitet …
mariadb-libs wird aktualisiert …
mariadb-clients wird aktualisiert …
mariadb wird aktualisiert …
:: MariaDB was updated to a new feature release. To update the data run:
systemctl restart mariadb.service && mariadb-upgrade -u root -p
:: Post-transaction-Hooks werden gestartet …
(1/5) Creating system user accounts...
(2/5) Reloading system manager configuration...
(3/5) Creating temporary files...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Refreshing PackageKit...
[1]+ digikam | tee -a ~/digikam.log &
Phase 1/7: Checking and upgrading mysql database
Processing databases
mysql
mysql.column_stats OK
mysql.columns_priv OK
mysql.db OK
mysql.event OK
mysql.func OK
mysql.global_priv OK
mysql.gtid_slave_pos OK
mysql.help_category OK
mysql.help_keyword OK
mysql.help_relation OK
mysql.help_topic OK
mysql.index_stats OK
mysql.innodb_index_stats OK
mysql.innodb_table_stats OK
mysql.plugin OK
mysql.proc OK
mysql.procs_priv OK
mysql.proxies_priv OK
mysql.roles_mapping OK
mysql.servers OK
mysql.table_stats OK
mysql.tables_priv OK
mysql.time_zone OK
mysql.time_zone_leap_second OK
mysql.time_zone_name OK
mysql.time_zone_transition OK
mysql.time_zone_transition_type OK
mysql.transaction_registry OK
Phase 2/7: Installing used storage engines... Skipped
Phase 3/7: Fixing views
mysql.user OK
sys.host_summary
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.host_summary_by_file_io
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.host_summary_by_file_io_type
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.host_summary_by_stages
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.host_summary_by_statement_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.host_summary_by_statement_type
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.innodb_buffer_stats_by_schema
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.innodb_buffer_stats_by_table
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.innodb_lock_waits
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.io_by_thread_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.io_global_by_file_by_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.io_global_by_file_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.io_global_by_wait_by_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.io_global_by_wait_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.latest_file_io
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.memory_by_host_by_current_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.memory_by_thread_by_current_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.memory_by_user_by_current_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.memory_global_by_current_bytes
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.memory_global_total
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.metrics OK
sys.processlist
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.ps_check_lost_instrumentation OK
sys.schema_auto_increment_columns OK
sys.schema_index_statistics
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.schema_object_overview OK
sys.schema_redundant_indexes OK
sys.schema_table_lock_waits
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.schema_table_statistics
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.schema_table_statistics_with_buffer
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.schema_tables_with_full_table_scans
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.schema_unused_indexes OK
sys.session
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.session_ssl_status OK
sys.statement_analysis
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.statements_with_errors_or_warnings
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.statements_with_full_table_scans
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.statements_with_runtimes_in_95th_percentile
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.statements_with_sorting
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.statements_with_temp_tables
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary_by_file_io
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary_by_file_io_type
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary_by_stages
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary_by_statement_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.user_summary_by_statement_type
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.version OK
sys.wait_classes_global_by_avg_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.wait_classes_global_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.waits_by_host_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.waits_by_user_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.waits_global_by_latency
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.x$host_summary OK
sys.x$host_summary_by_file_io OK
sys.x$host_summary_by_file_io_type OK
sys.x$host_summary_by_stages OK
sys.x$host_summary_by_statement_latency OK
sys.x$host_summary_by_statement_type OK
sys.x$innodb_buffer_stats_by_schema OK
sys.x$innodb_buffer_stats_by_table OK
sys.x$innodb_lock_waits OK
sys.x$io_by_thread_by_latency OK
sys.x$io_global_by_file_by_bytes OK
sys.x$io_global_by_file_by_latency OK
sys.x$io_global_by_wait_by_bytes OK
sys.x$io_global_by_wait_by_latency OK
sys.x$latest_file_io OK
sys.x$memory_by_host_by_current_bytes OK
sys.x$memory_by_thread_by_current_bytes OK
sys.x$memory_by_user_by_current_bytes OK
sys.x$memory_global_by_current_bytes OK
sys.x$memory_global_total OK
sys.x$processlist OK
sys.x$ps_digest_95th_percentile_by_avg_us OK
sys.x$ps_digest_avg_latency_distribution OK
sys.x$ps_schema_table_statistics_io
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.x$schema_flattened_keys OK
sys.x$schema_index_statistics OK
sys.x$schema_table_lock_waits
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.x$schema_table_statistics
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.x$schema_table_statistics_with_buffer
Error : Cannot load from mysql.proc. The table is probably corrupted
error : Corrupt
sys.x$schema_tables_with_full_table_scans OK
sys.x$session OK
sys.x$statement_analysis OK
sys.x$statements_with_errors_or_warnings OK
sys.x$statements_with_full_table_scans OK
sys.x$statements_with_runtimes_in_95th_percentile OK
sys.x$statements_with_sorting OK
sys.x$statements_with_temp_tables OK
sys.x$user_summary OK
sys.x$user_summary_by_file_io OK
sys.x$user_summary_by_file_io_type OK
sys.x$user_summary_by_stages OK
sys.x$user_summary_by_statement_latency OK
sys.x$user_summary_by_statement_type OK
sys.x$wait_classes_global_by_avg_latency OK
sys.x$wait_classes_global_by_latency OK
sys.x$waits_by_host_by_latency OK
sys.x$waits_by_user_by_latency OK
sys.x$waits_global_by_latency OK
Phase 4/7: Running 'mysql_fix_privilege_tables'
Phase 5/7: Fixing table and database names
Phase 6/7: Checking and upgrading tables
Processing databases
db155324x1622487
db155324x1622487.backend_layout OK
db155324x1622487.be_groups OK
db155324x1622487.be_sessions OK
db155324x1622487.be_users OK
db155324x1622487.cache_imagesizes OK
db155324x1622487.cache_md5params OK
db155324x1622487.cache_treelist OK
db155324x1622487.cache_typo3temp_log OK
db155324x1622487.cf_cache_hash OK
db155324x1622487.cf_cache_hash_tags OK
db155324x1622487.cf_cache_pages OK
db155324x1622487.cf_cache_pages_tags OK
db155324x1622487.cf_cache_pagesection OK
db155324x1622487.cf_cache_pagesection_tags OK
db155324x1622487.cf_cache_rootline OK
db155324x1622487.cf_cache_rootline_tags OK
db155324x1622487.cf_extbase_datamapfactory_datamap OK
db155324x1622487.cf_extbase_datamapfactory_datamap_tags OK
db155324x1622487.cf_extbase_object OK
db155324x1622487.cf_extbase_object_tags OK
db155324x1622487.cf_extbase_reflection OK
db155324x1622487.cf_extbase_reflection_tags OK
db155324x1622487.cf_extbase_typo3dbbackend_tablecolumns OK
db155324x1622487.cf_extbase_typo3dbbackend_tablecolumns_tags OK
db155324x1622487.cf_tt_news_cache OK
db155324x1622487.cf_tt_news_cache_tags OK
db155324x1622487.cf_workspaces_cache OK
db155324x1622487.cf_workspaces_cache_tags OK
db155324x1622487.fe_groups OK
db155324x1622487.fe_session_data OK
db155324x1622487.fe_sessions OK
db155324x1622487.fe_users OK
db155324x1622487.index_config OK
db155324x1622487.index_debug OK
db155324x1622487.index_fulltext OK
db155324x1622487.index_grlist OK
db155324x1622487.index_phash OK
db155324x1622487.index_rel OK
db155324x1622487.index_section OK
db155324x1622487.index_stat_search OK
db155324x1622487.index_stat_word OK
db155324x1622487.index_words OK
db155324x1622487.pages OK
db155324x1622487.pages_language_overlay OK
db155324x1622487.static_countries OK
db155324x1622487.static_country_zones OK
db155324x1622487.static_currencies OK
db155324x1622487.static_languages OK
db155324x1622487.static_territories OK
db155324x1622487.static_tsconfig_help OK
db155324x1622487.sys_be_shortcuts OK
db155324x1622487.sys_category OK
db155324x1622487.sys_category_record_mm OK
db155324x1622487.sys_collection OK
db155324x1622487.sys_collection_entries OK
db155324x1622487.sys_domain OK
db155324x1622487.sys_file OK
db155324x1622487.sys_file_collection OK
db155324x1622487.sys_file_processedfile OK
db155324x1622487.sys_file_reference OK
db155324x1622487.sys_file_storage OK
db155324x1622487.sys_filemounts OK
db155324x1622487.sys_history OK
db155324x1622487.sys_language OK
db155324x1622487.sys_lockedrecords OK
db155324x1622487.sys_log OK
db155324x1622487.sys_news OK
db155324x1622487.sys_note OK
db155324x1622487.sys_preview OK
db155324x1622487.sys_refindex OK
db155324x1622487.sys_registry OK
db155324x1622487.sys_template OK
db155324x1622487.sys_workspace OK
db155324x1622487.sys_workspace_stage OK
db155324x1622487.tt_content OK
db155324x1622487.tt_news OK
db155324x1622487.tt_news_cache OK
db155324x1622487.tt_news_cache_tags OK
db155324x1622487.tt_news_cat OK
db155324x1622487.tt_news_cat_mm OK
db155324x1622487.tt_news_related_mm OK
db155324x1622487.tx_bnbbackupext_domain_model_bnbbackup OK
db155324x1622487.tx_extensionmanager_domain_model_extension OK
digikam
digikam.AlbumRoots OK
digikam.Albums OK
digikam.DownloadHistory OK
digikam.ImageComments OK
digikam.ImageCopyright OK
digikam.ImageHistory OK
digikam.ImageInformation OK
digikam.ImageMetadata OK
digikam.ImagePositions OK
digikam.ImageProperties OK
digikam.ImageRelations OK
digikam.ImageTagProperties OK
digikam.ImageTags OK
digikam.Images OK
digikam.Searches OK
digikam.Settings OK
digikam.TagProperties OK
digikam.Tags OK
digikam.TagsTree OK
digikam.VideoMetadata OK
digikam_face
digikam_face.FaceMatrices OK
digikam_face.FaceSettings OK
digikam_face.Identities OK
digikam_face.IdentityAttributes OK
digikam_face.KDTree OK
digikam_similarity
digikam_similarity.ImageHaarMatrix OK
digikam_similarity.ImageSimilarity OK
digikam_similarity.SimilaritySettings OK
digikam_thumbs
digikam_thumbs.CustomIdentifiers OK
digikam_thumbs.FilePaths OK
digikam_thumbs.ThumbSettings OK
digikam_thumbs.Thumbnails OK
digikam_thumbs.UniqueHashes OK
information_schema
performance_schema
sys
sys.sys_config OK
test
Phase 7/7: Running 'FLUSH PRIVILEGES'
OK
Ctrl-C -- exit!
digikam | tee -a ~/digikam.log

[testuser@tuxedo ~]$ mysql -u root -p
Enter password:
CREATE USER 'testuserDigikam'@'localhost' IDENTIFIED BY 'password';
GRANT ALL ON *.* TO 'testuserDigikam'@'localhost' IDENTIFIED BY 'password';
CREATE DATABASE testuserDigikam;
GRANT ALL PRIVILEGES ON testuserDigikam.* TO 'testuserDigikam'@'localhost';
CREATE DATABASE testuserDigikam_thumbs;
GRANT ALL PRIVILEGES ON testuserDigikam_thumbs.* TO 'testuserDigikam'@'localhost';
CREATE DATABASE testuserDigikam_faces;
GRANT ALL PRIVILEGES ON testuserDigikam_faces.* TO 'testuserDigikam'@'localhost';
CREATE DATABASE testuserDigikam_similarity;
GRANT ALL PRIVILEGES ON testuserDigikam_similarity.* TO 'testuserDigikam'@'localhost';
FLUSH PRIVILEGES;
[testuser@tuxedo ~]$ fg
digikam | tee -a ~/digikam.log
QFSFileEngine::open: No file name specified
digikam.facedb: Cannot found faces engine model "shapepredictor.dat"
digikam.facedb: Faces recognition feature cannot be used!
digikam.facedb: Cannot found faces engine DNN model "openface_nn4.small2.v1.t7"
digikam.facedb: Faces recognition feature cannot be used!
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
QPixmap::scaled: Pixmap is a null pixmap
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = digikam path = /usr/bin pid = 216546
KCrash: Arguments: /usr/bin/digikam
KCrash: Attempting to start /usr/lib/drkonqi
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
Invalid write to eventfd: Ungültiger Dateideskriptor
Code should not be reached at ../pulseaudio/src/pulsecore/fdsem.c:199, function pa_fdsem_post(). Aborting.
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
[testuser@tuxedo ~]$
Comment by Antonio Rojas (arojas) - Sunday, 25 July 2021, 14:04 GMT
Please test 7.3.0-3
Comment by maderios (maderios) - Sunday, 25 July 2021, 16:20 GMT
I tested digikam 7.3.0-3 with new empty db mariadb 10.6.3 with new user. Checking connection db works but then, it could not create tables.
After deleting 'QMYSQL' in digikamrc I could restart digikam and see again mysql setting dialog box -> database connection test -> successfull
-> OK -> but then message 'the database is not valid The "DBVersion" setting doesnt exist...'
It's not surprising because tables were not created.
Message console:
digikam.coredb: Core database: cannot process schema initialization
Same issue with digikam git master version.
Comment by Jürgen Blumenschein (jblume) - Sunday, 25 July 2021, 16:20 GMT
Same problem after updating to 7.3.0-3, updating to mariadb{,clients,libs} to 10.6.3
and "sudo systemctl restart mariadb.service && sudo mariadb-upgrade -u root -p" with result OK.
Crash happens when moving mouse over a thumbnail of the last imported pictures.:

[juergen@tuxedo ~]$ digikam
QtAV 1.13.0(Jul 11 2019, 03:26:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
digikam.general: Failed to find parent tag for tag "Birke" with pid 229
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = digikam path = /usr/bin pid = 230627
KCrash: Arguments: /usr/bin/digikam
KCrash: Attempting to start /usr/lib/drkonqi
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
Invalid write to eventfd: Ungültiger Dateideskriptor
Code should not be reached at ../pulseaudio/src/pulsecore/fdsem.c:199, function pa_fdsem_post(). Aborting.
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
Abgebrochen (Speicherabzug geschrieben)
Comment by Jürgen Blumenschein (jblume) - Sunday, 25 July 2021, 16:27 GMT
Re-downgrading do mariadb{,clients,libs} to 10.5.11 solved the issue.
Comment by Antonio Rojas (arojas) - Sunday, 25 July 2021, 18:05 GMT
@everybody: please refrain from refreshing the page after posting comments.
Comment by maderios (maderios) - Sunday, 25 July 2021, 18:10 GMT
> It's not surprising because tables were not created
It's a mistake. Phpmyadmin shows 20 tables were created in my new db but digikam still refuses to start.
After that, i downgraded to mariadb 10.5.11. I get same message 'the database is not valid The "DBVersion" setting doesnt exist...'
May be db was corrupted with buggy 10.6.3 mariadb
After downgrading mariadb, i deleted tables and digikamrc then start digikam 7.3.0-3. I could create mariadb db normally.
I think it's mariadb 10.6.3 bug, not digikam.
Comment by maderios (maderios) - Monday, 26 July 2021, 08:22 GMT

Comment by maderios (maderios) - Monday, 26 July 2021, 09:27 GMT Comment by Antonio Rojas (arojas) - Monday, 26 July 2021, 09:48 GMT
@jblume please test 7.3.0-4
Comment by maderios (maderios) - Monday, 26 July 2021, 10:04 GMT
digikam 7.3.0-4 works with mariadb 10.6.3 but updating db takes a very long time (20.000 images)
Comment by Jürgen Blumenschein (jblume) - Monday, 26 July 2021, 10:23 GMT
testuser-account worked as aspected but my working account still crashs.
I'll try now to reimport my 100k-pictures collection into a new created database.
This will last, hope it works.
Comment by Jürgen Blumenschein (jblume) - Monday, 26 July 2021, 10:43 GMT
New database doesn't help, crashes after about a minute:

[juergen@tuxedo .config]$ digikam
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPainter::begin: Paint device returned engine == 0, type: 2
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 12302, resource id: 18886677, major code: 40 (TranslateCoords), minor code: 0
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QPixmap::scaleWidth: Pixmap is a null pixmap
QEventLoop::exec: instance 0x55f4aca4ea00 has already called exec()
QEventLoop::exec: instance 0x55f4aca4ea00 has already called exec()
QtAV 1.13.0(Jul 11 2019, 03:26:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
digikam.metaengine: Cannot load metadata from file with Exiv2 backend: /home/juergen/Bilder/1960_bis_1969/1969/PICT0072.XCF (Error # 11 : "/home/juergen/Bilder/1960_bis_1969/1969/PICT0072.XCF: Die Datei enthält Daten eines unbekannten Bildtyps."
digikam.metaengine: Cannot load metadata from file with Exiv2 backend: /home/juergen/Bilder/1970_bis_1979/Paris_Sessel_vor_Plakaten.xcf (Error # 11 : "/home/juergen/Bilder/1970_bis_1979/Paris_Sessel_vor_Plakaten.xcf: Die Datei enthält Daten eines unbekannten Bildtyps."
digikam.metaengine: Cannot load metadata from file with Exiv2 backend: /home/juergen/Bilder/1970_bis_1979/1974/_.png (Error # 11 : "/home/juergen/Bilder/1970_bis_1979/1974/_.png: Die Datei enthält Daten eines unbekannten Bildtyps."
digikam.dimg.png: Not a PNG image file.
digikam.metaengine: Cannot load metadata from file with Exiv2 backend: /home/juergen/Bilder/1970_bis_1979/1974/_.png (Error # 11 : "/home/juergen/Bilder/1970_bis_1979/1974/_.png: Die Datei enthält Daten eines unbekannten Bildtyps."
digikam.dimg.png: Not a PNG image file.
digikam.metaengine: Cannot load metadata with Exiv2: (Error # 11 : "/home/juergen/Bilder/1970_bis_1979/1974/_.png: Die Datei enthält Daten eines unbekannten Bildtyps."
digikam.general: Cannot create thumbnail for "/home/juergen/Bilder/1970_bis_1979/1974/_.png"
digikam.general: Thumbnail is null for "/home/juergen/Bilder/1970_bis_1979/1974/_.png"
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
*** Warning: UniqueCameraModel string has trailing blanks ***
KCrash: crashing... crashRecursionCounter = 2
KCrash: Application Name = digikam path = /usr/bin pid = 6155
KCrash: Arguments: /usr/bin/digikam
KCrash: Attempting to start /usr/lib/drkonqi
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
pa_write() failed while trying to wake up the mainloop: Ungültiger Dateideskriptor
Invalid write to eventfd: Ungültiger Dateideskriptor
Code should not be reached at ../pulseaudio/src/pulsecore/fdsem.c:199, function pa_fdsem_post(). Aborting.
Unable to start Dr. Konqi
Re-raising signal for core dump handling.
Abgebrochen (Speicherabzug geschrieben)
Comment by Antonio Rojas (arojas) - Monday, 26 July 2021, 12:15 GMT
OK thanks, I can reproduce now (it needs a large database)
Comment by Jürgen Blumenschein (jblume) - Thursday, 12 August 2021, 07:46 GMT
It look likes that the problem ist solved with mariadb 10.6.4:

$ sudo sed -e 's/IgnorePkg = mariadb-clients mariadb-libs mariadb/# IgnorePkg = mariadb-clients mariadb-libs mariadb/' /etc/pacman.conf -i ; sudo pacman -Sy mariadb; digikam
:: Paketdatenbanken werden synchronisiert …
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
arcolinux_repo ist aktuell
arcolinux_repo_3party ist aktuell
arcolinux_repo_submicron ist aktuell
userrepository ist aktuell
Fehler: Konnte Datei 'arcolinux_repo_submicron.db' nicht von bike.seedhost.eu übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'arcolinux_repo.db' nicht von bike.seedhost.eu übertragen : The requested URL returned error: 404
Fehler: Konnte Datei 'arcolinux_repo_3party.db' nicht von bike.seedhost.eu übertragen : The requested URL returned error: 404
Warnung: too many errors from bike.seedhost.eu, skipping for the remainder of this transaction
Abhängigkeiten werden aufgelöst …
Nach in Konflikt stehenden Paketen wird gesucht …

Paket (3) Alte Version Neue Version Netto-Veränderung

extra/mariadb-clients 10.5.11-1 10.6.4-1 0,48 MiB
extra/mariadb-libs 10.5.11-1 10.6.4-1 -0,01 MiB
extra/mariadb 10.5.11-1 10.6.4-1 0,69 MiB

Gesamtgröße der installierten Pakete: 303,86 MiB
Größendifferenz der Aktualisierung: 1,16 MiB

:: Installation fortsetzen? [J/n]

(3/3) Schlüssel im Schlüsselbund werden geprüft [--------------------------------------------------------------------] 100%
(3/3) Paket-Integrität wird überprüft [--------------------------------------------------------------------] 100%
(3/3) Paket-Dateien werden geladen [--------------------------------------------------------------------] 100%
(3/3) Auf Dateikonflikte wird geprüft [--------------------------------------------------------------------] 100%
(3/3) Verfügbarer Festplattenspeicher wird ermittelt [--------------------------------------------------------------------] 100%
:: Paketänderungen werden verarbeitet …
(1/3) Aktualisierung läuft mariadb-libs [--------------------------------------------------------------------] 100%
(2/3) Aktualisierung läuft mariadb-clients [--------------------------------------------------------------------] 100%
(3/3) Aktualisierung läuft mariadb [--------------------------------------------------------------------] 100%
:: MariaDB was updated to a new feature release. To update the data run:
systemctl restart mariadb.service && mariadb-upgrade -u root -p
:: Post-transaction-Hooks werden gestartet …
(1/5) Creating system user accounts...
(2/5) Reloading system manager configuration...
(3/5) Creating temporary files...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Refreshing PackageKit...

QtAV 1.13.0(Jul 11 2019, 03:26:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai, China Copyright (C) 2012-2019 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
kf.xmlgui: Unhandled container to remove : Digikam::DigikamApp
[ALSOFT] (EE) Failed to set real-time priority for thread: Die Operation ist nicht erlaubt (1)
QThreadStorage: Thread 0x561031fdd540 exited after QThreadStorage 16 destroyed
QThreadStorage: Thread 0x561031fdd540 exited after QThreadStorage 13 destroyed
QThreadStorage: Thread 0x561032872b90 exited after QThreadStorage 16 destroyed
QThreadStorage: Thread 0x561032872b90 exited after QThreadStorage 13 destroyed
QThreadStorage: Thread 0x561032870250 exited after QThreadStorage 16 destroyed
QThreadStorage: Thread 0x561032870250 exited after QThreadStorage 13 destroyed
Comment by Antonio Rojas (arojas) - Thursday, 12 August 2021, 08:00 GMT
I can still reproduce the crashes and slowness on refreshing the database. Perhaps it was a different issue after all, but let's kepp this open to track it.
Comment by maderios (maderios) - Thursday, 12 August 2021, 09:18 GMT
Same slowness when refreshing db
10.6.4 is unusable
Comment by Jürgen Blumenschein (jblume) - Thursday, 12 August 2021, 15:14 GMT
I graded up mariadb on my two other ArchLinux machines. There I have no more problems too.

Loading...