Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71569 - [bolt] Unable to use thunderbolt after upgrade 5.13.4

Attached to Project: Community Packages
Opened by Obs (obspm) - Wednesday, 21 July 2021, 07:23 GMT
Last edited by Morten Linderud (Foxboron) - Tuesday, 17 August 2021, 12:11 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Morten Linderud (Foxboron)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 28
Private No

Details

Description:

After upgrading to kernel 5.13.4 the thunderbolt stop working. Unable to contact my dock (Dell WD19TB Thunderbolt Dock) and even the command boltctl hung

Downgrade to 5.12.15-arch1-1 make everything work fine.


Additional info:

* package version(s) : All up2date
* config and/or log files etc. : No specific configuration.


This task depends upon

Closed by  Morten Linderud (Foxboron)
Tuesday, 17 August 2021, 12:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  Kernel has fixed the userspace regression.
Comment by Eric Krebs (ekrebs) - Wednesday, 21 July 2021, 18:13 GMT
Looks like this is a known issue with bolt: https://gitlab.freedesktop.org/bolt/bolt/-/issues/174
Comment by Morten Linderud (Foxboron) - Wednesday, 21 July 2021, 18:48 GMT
This is a bolt issue, not a kernel issue. Downgrading bolt to the `0.8-1` release also works.
Comment by Stephan (smoneck) - Friday, 23 July 2021, 14:10 GMT
Downgrading the kernel from 5.13.4 to 5.12.15 did it for me for now.

~ 0 ~

Search the package cache for old versions:

> cd /var/cache/pacman/pkg/
> ls | grep ^linux

Install one. E.g.:

> pacman -U linux-5.12.15.arch1-1-x86_64.pkg.tar.zst linux-headers-5.12.15.arch1-1-x86_64.pkg.tar.zst
Comment by Elijah Lynn (ElijahLynn) - Friday, 23 July 2021, 18:23 GMT
Thanks Morten, 0.8-3 is also working for me, I ran `sudo pacman -U /var/cache/pacman/pkg/bolt-0.8-3-x86_64.pkg.tar.zst` worked for me and my Thinkpad Thunderbolt Dock and peripherals are working again.
Comment by Elijah Lynn (ElijahLynn) - Friday, 23 July 2021, 18:24 GMT Comment by pebcak (pebcak) - Saturday, 24 July 2021, 15:45 GMT
Have the same issue. Reported in the Testing Repo Forum 2021-07-15:
https://bbs.archlinux.org/viewtopic.php?id=267977

I am a bit intrigued though since bolt 0.9.1-1 works as expected on LTS kernel (5.10.52-1-lts) on my system.
Comment by loqs (loqs) - Monday, 26 July 2021, 19:35 GMT
The kernel change in 5.13 6f3badead6a078cf3c71f381f9d84ac922984a00 will most likely be reverted for breaking userspace [1]. Which revealed the use of an uninitialized string pointer in boltd when the authorized attribute is not found.
Edit:
Revert of kernel change in progress [2].

[1] https://bugzilla.redhat.com/show_bug.cgi?id=1979765#c16
[2] https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/usb.git/commit/?h=usb-linus
Comment by pebcak (pebcak) - Thursday, 29 July 2021, 09:52 GMT
Still unresolved in: 5.13.6-zen1-1-zen (currently in Testing repo)
Comment by Moabit (Moabit) - Thursday, 29 July 2021, 10:20 GMT Comment by loqs (loqs) - Monday, 09 August 2021, 15:25 GMT Comment by Cyrinux (cyrinux) - Tuesday, 10 August 2021, 07:06 GMT
Comment by Morten Linderud (Foxboron) - Tuesday, 10 August 2021, 07:17 GMT
Please refrain from commenting "Me too" and use the vote button. Use the comments for status updates and new insight.
Comment by Steve Balboa (steveb) - Friday, 13 August 2021, 20:19 GMT
Problem solved with 5.13.10-arch1-1

Loading...