Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71568 - [chromium] Network service crashing

Attached to Project: Arch Linux
Opened by Jürgen Richtsfeld (juri8) - Wednesday, 21 July 2021, 07:03 GMT
Last edited by Evangelos Foutras (foutrelis) - Wednesday, 21 July 2021, 16:42 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Evangelos Foutras (foutrelis)
Felix Yan (felixonmars)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
Chromium doesn't seem to be able to load any website.

Additional info:
* Version: 92.0.4515.107-1

Steps to reproduce:
When I launch chromium from a shell (to get output - it's also reproducible when launching in other ways)
not a single tab can be shown and the console contains:
```
[12574:12574:0721/090234.797017:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[12542:12542:0721/090235.304956:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[12542:12542:0721/090236.669757:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[12542:12542:0721/090237.369427:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[0721/090237.455384:WARNING:process_reader_linux.cc(125)] no stack mapping
[12542:12542:0721/090237.839466:ERROR:network_service_instance_impl.cc(331)] Network service crashed, restarting service.
[12832:12835:0721/090237.899853:ERROR:ssl_client_socket_impl.cc(981)] handshake failed; returned -1, SSL error code 1, net_error -100
```

Everything worked nicely until yesterday's version (whatever I had, but I update every day)
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Wednesday, 21 July 2021, 16:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  chromium 92.0.4515.107-3 contains the upstream fix for this
Comment by Cedric Girard (Xdark) - Wednesday, 21 July 2021, 07:46 GMT
I confirm downgrading 92.0.4515.107-1 => 91.0.4472.164-1 fixes it.
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 July 2021, 08:13 GMT Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 July 2021, 10:16 GMT
Pushed chromium 92.0.4515.107-2 which is built with use_allocator="none" and thus seems to avoid triggering this issue. (We can't do much about Chrome and other proprietary browsers though.)
Comment by Evangelos Foutras (foutrelis) - Wednesday, 21 July 2021, 12:55 GMT
Removed the systemd tag as this appears to be caused by Chromium's PartitionAlloc.

Loading...