Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71560 - [podman] writing file `/sys/fs/cgroup/cgroup.subtree_control`: Invalid argument

Attached to Project: Community Packages
Opened by Cedric Girard (Xdark) - Tuesday, 20 July 2021, 17:13 GMT
Last edited by Morten Linderud (Foxboron) - Thursday, 22 July 2021, 10:58 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Morten Linderud (Foxboron)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Since the switch from runc to crun, I cannot use podman anymore. Whenever I try to start a container (as root) I get the following error: "writing file `/sys/fs/cgroup/cgroup.subtree_control`: Invalid argument"

I have tried removing runc to be sure that I am using crun, without any change. I have no customization in /etc/containers/containers.conf


Additional info:
* package version(s):
* podman 3.2.2-2
* crun 0.20.1-2
* containers-common 0.41.0-2

This task depends upon

Closed by  Morten Linderud (Foxboron)
Thursday, 22 July 2021, 10:58 GMT
Reason for closing:  Not a bug
Additional comments about closing:  cgroup2 doesn't support realtime processes which causes a conflict
Comment by Morten Linderud (Foxboron) - Wednesday, 21 July 2021, 11:02 GMT
Please provide all the commands you are running. It's not a packaging bug if I can't reproduce it :D
Comment by Cedric Girard (Xdark) - Wednesday, 21 July 2021, 16:46 GMT
Any command that involves running a container fails. Example

```
>sudo podman run docker.io/alpine:latest
Trying to pull docker.io/library/alpine:latest...
Getting image source signatures
Copying blob 5843afab3874 [--------------------------------------] 0.0b / 0.0b
Copying config d4ff818577 done
Writing manifest to image destination
Storing signatures
Error: OCI runtime error: writing file `/sys/fs/cgroup/cgroup.subtree_control`: Invalid argument
```
Comment by Cedric Girard (Xdark) - Wednesday, 21 July 2021, 17:30 GMT
I have opened an upstream issue as well: https://github.com/containers/crun/issues/704
Comment by Morten Linderud (Foxboron) - Wednesday, 21 July 2021, 18:42 GMT
Works for me. Output of "mount | grep cgroup" and "ls /sys/fs/cgroup"
Comment by Cedric Girard (Xdark) - Wednesday, 21 July 2021, 20:39 GMT
Here you are:

cgroup2 on /sys/fs/cgroup type cgroup2 (rw,nosuid,nodev,noexec,relatime)

-r--r--r-- 1 root root 0 Jul 21 18:44 cgroup.controllers
-rw-r--r-- 1 root root 0 Jul 21 22:38 cgroup.max.depth
-rw-r--r-- 1 root root 0 Jul 21 22:38 cgroup.max.descendants
-rw-r--r-- 1 root root 0 Jul 21 22:38 cgroup.procs
-r--r--r-- 1 root root 0 Jul 21 22:38 cgroup.stat
-rw-r--r-- 1 root root 0 Jul 21 19:23 cgroup.subtree_control
-rw-r--r-- 1 root root 0 Jul 21 22:38 cgroup.threads
-rw-r--r-- 1 root root 0 Jul 21 22:38 cpu.pressure
-r--r--r-- 1 root root 0 Jul 21 22:38 cpuset.cpus.effective
-r--r--r-- 1 root root 0 Jul 21 22:38 cpuset.mems.effective
-r--r--r-- 1 root root 0 Jul 21 22:38 cpu.stat
drwxr-xr-x 2 root root 0 Jul 21 19:23 dev-hugepages.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 dev-mqueue.mount
drwxr-xr-x 2 root root 0 Jul 21 22:20 init.scope
-rw-r--r-- 1 root root 0 Jul 21 22:38 io.cost.model
-rw-r--r-- 1 root root 0 Jul 21 22:38 io.cost.qos
-rw-r--r-- 1 root root 0 Jul 21 22:38 io.pressure
-r--r--r-- 1 root root 0 Jul 21 22:38 io.stat
drwxr-xr-x 2 root root 0 Jul 21 19:23 machine.slice
-r--r--r-- 1 root root 0 Jul 21 22:38 memory.numa_stat
-rw-r--r-- 1 root root 0 Jul 21 22:38 memory.pressure
-r--r--r-- 1 root root 0 Jul 21 22:38 memory.stat
drwxr-xr-x 2 root root 0 Jul 21 19:23 proc-fs-nfsd.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 proc-sys-fs-binfmt_misc.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 sys-fs-fuse-connections.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 sys-kernel-config.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 sys-kernel-debug.mount
drwxr-xr-x 2 root root 0 Jul 21 19:23 sys-kernel-tracing.mount
drwxr-xr-x 66 root root 0 Jul 21 22:35 system.slice
drwxr-xr-x 4 root root 0 Jul 21 19:23 user.slice
Comment by Cedric Girard (Xdark) - Thursday, 22 July 2021, 07:25 GMT
It is working rootless but not as root.

I have tried adding manually cpuset and cpu to /sys/fs/cgroup/cgroup.subtree_control but they disappear once I get the error as root.

Loading...