Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7155 - pacman failed to commit transaction (invalid or corrupted package)

Attached to Project: Pacman
Opened by Mildred (mildred) - Sunday, 13 May 2007, 21:03 GMT
Last edited by Dan McGee (toofishes) - Wednesday, 16 January 2008, 05:18 GMT
Task Type Bug Report
Category Backend/Core
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity Low
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I decided to upgrade my sytem. So I typed pacman -Syu. It downloaded packages but at the end I had :

checking package integrity... done.
error: failed to commit transaction (invalid or corrupted package)

I assume that some downloaded file didn't pass the integrity check. But there is no way to know which package is misdownloaded and I have to delete the complete package cache in order to force pacman to redownload all packages (even those which were correctly downloaded).

Note that I'm using the new pacman 3.0
This task depends upon

Closed by  Dan McGee (toofishes)
Wednesday, 16 January 2008, 05:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in newer versions of pacman
Comment by Dan McGee (toofishes) - Monday, 14 May 2007, 04:39 GMT
Was abiword involved during this operation? If so, we fixed that problem earlier today.

It would help more if you post or attach the full output instead of just a snippit.
Comment by Mildred (mildred) - Monday, 14 May 2007, 07:44 GMT
Yes, it involves abiword. Sorry for filling a bug that was already known. But I still think that pacman should tell which package failed the check because it already happened me before to have failed downloads and having to remove the package that was not correctly downloaded. (I knew which one it was, it was the only one that was downloaded beyond 100%).
At least show this informtion in verbose mode

The full output:

sudo pacman -Su
:: Starting full system upgrade...
warning: plan9port: local (20070408-1) is newer than community (20051127-1)
warning: pommed: local (1.3-2) is newer than community (1.3-1)
warning: qt4: local (4.3.0_snapshot_20070417-1) is newer than community (4.2.3-2)
resolving dependencies... done.
looking for inter-conflicts... done.

Targets: abiword-2.4.6-1.1 alsa-lib-1.0.14rc3-2 alsa-plugins-1.0.14rc4-1
alsa-utils-1.0.14rc2-2 bash-3.2.017-1 bluez-libs-3.10-1 bzr-0.16-1
claws-mail-2.9.2-1 device-mapper-1.02.19-1 cryptsetup-1.0.5-2
dnsutils-9.4.1-1 esd-0.2.38-1 gcc-4.1.2-4 pcre-7.1-1 exim-4.67-1
filesystem-0.8-7 fuse-2.6.5-1 perl-error-0.17008-4 git-1.5.1.3-2
gnupg2-2.0.4-1 gsl-1.9-1 hdparm-7.3-1 hwdetect-0.8-7 udev-111-1
initscripts-0.8-12 inputproto-1.4.2-1 iputils-20070202-1
klibc-udev-111-2 mkinitcpio-0.5.14-1 kernel26-2.6.21.1-8
libexif-0.6.14-1 libgtop-2.14.9-1 libmysqlclient-5.0.41-1
libxcomposite-0.3.2-1 lirc-0.8.1-6 lvm2-2.02.25-2 man-pages-2.46-1
mdadm-2.6.1-2 metacity-2.18.2-3 mpc-0.12.1-2 nano-2.0.6-1
nautilus-actions-1.4.1-1 nautilus-open-terminal-0.8-1
wireless_tools-29pre21-1 ndiswrapper-utils-1.43-1
ndiswrapper-1.43-1 php-5.2.2-2 portmap-6.0-1
postgresql-libs-8.2.4-1 psmisc-22.5-1 ruby-1.8.6-1
sqlite3-3.3.17-1 vim-7.0.243-1 wpa_supplicant-0.5.7-3
xf86-input-keyboard-1.1.1-1 xf86-input-mouse-1.2.1-1
xf86-video-vesa-1.3.0-1 xorg-xinit-1.0.3-2

Total Package Size: 95.22 MB

Proceed with installation? [Y/n] y
checking package integrity... done.
error: failed to commit transaction (invalid or corrupted package)

Comment by Dan McGee (toofishes) - Monday, 14 May 2007, 14:23 GMT
Yes, I agree the error message could be a bit more verbose- I know in other cases it is, odd that in this one it is not.
Comment by Allan McRae (Allan) - Sunday, 23 December 2007, 05:16 GMT
I think this is fixed now as you now get queried for each corrupted package found.
Comment by Vinay S Shastry (shastry) - Saturday, 06 October 2012, 21:14 GMT
02:39:58 %] sudo pacman -Su [~]
:: Starting full system upgrade...
warning: unison: ignoring package upgrade (2.40.63-1 => 2.40.65-1)
resolving dependencies...
looking for inter-conflicts...

Targets (19):

Name Old Version New Version Net Change Download Size

filesystem 2012.8-1 2012.10-1 0.00 MiB
hdparm 9.39-1 9.42-1 0.00 MiB
jack 0.121.3-6 0.121.3-7 0.11 MiB
libreoffice-base 3.6.1-4 3.6.2-1 0.00 MiB
libreoffice-calc 3.6.1-4 3.6.2-1 0.00 MiB
libreoffice-common 3.6.1-4 3.6.2-1 -0.05 MiB
libreoffice-draw 3.6.1-4 3.6.2-1 0.00 MiB
libreoffice-en-GB 3.6.1-1 3.6.2-1 0.01 MiB
libreoffice-gnome 3.6.1-4 3.6.2-1 0.07 MiB
libreoffice-impress 3.6.1-4 3.6.2-1 0.00 MiB
libreoffice-math 3.6.1-4 3.6.2-1 0.00 MiB
libreoffice-writer 3.6.1-4 3.6.2-1 0.01 MiB
libshout 1:2.3.0-1 1:2.3.1-1 0.00 MiB
libusbx 1.0.12-2 1.0.14-1 0.00 MiB
netcfg 2.8.10-1 2.8.11-1 0.12 MiB
sqlite 3.7.14-1 3.7.14.1-1 0.00 MiB
systemd 193-1 194-1 0.01 MiB
systemd-sysvcompat 193-1 194-1 0.00 MiB
util-linux 2.22-6 2.22-7 0.00 MiB

Total Installed Size: 350.53 MiB
Net Upgrade Size: 0.27 MiB

Proceed with installation? [Y/n]
(19/19) checking package integrity [######################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.
zsh: exit 1 sudo pacman -Su


02:43:40 %] pacman -V [~]

.--. Pacman v4.0.3 - libalpm v7.0.3
/ _.-' .-. .-. .-. Copyright (C) 2006-2012 Pacman Development Team
\ '-. '-' '-' '-' Copyright (C) 2002-2006 Judd Vinet
'--'
This program may be freely redistributed under
the terms of the GNU General Public License.

zsh: exit 2 pacman -V

Loading...