Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#71549 - [nextcloud] nextcloud is currently not compatible with mariadb 10.6.x

Attached to Project: Community Packages
Opened by Gunnar Bretthauer (Taijian) - Monday, 19 July 2021, 20:42 GMT
Last edited by David Runge (dvzrv) - Sunday, 20 February 2022, 13:47 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
David Runge (dvzrv)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No



After the upgrade of mariadb to 10.6.3 today, nextcloud refused to update to 22.0.0-2. I have tracked this down to this issue [1] with the following solution [2].

Users should be encouraged to create a drop-in config snippet in /etc/my.cnf.d/ setting innodb_read_only_compressed=OFF. Ideally, this could be part of this package.

Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1. Upgrade mariadb to 10.6.x
2. Try to invoke the occ script.

This task depends upon

Closed by  David Runge (dvzrv)
Sunday, 20 February 2022, 13:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with mariadb >= 10.6.6 (by mariadb upstream not hard-deprecating the feature)
Comment by George Rawlinson (rawlinsong) - Tuesday, 20 July 2021, 07:34 GMT
Hey Gunnar, that workaround is better suited to the Nextcloud page on the Arch Wiki, rather than in the package itself. Feel free to add it to the wiki page.
Comment by Dominik Schrempf (dschrempf) - Tuesday, 20 July 2021, 08:45 GMT
Interestingly, I had both updates at the same time, and the upgrade to Nextcloud 22 worked fine (I guess the old version of MariaDB was still running during the upgrade). However, after a reboot Nextcloud stopped working. It took me quite a while to figure out that MariaDB 10.6 was the cause for this breakage. The setting `innodb_read_only_compressed=OFF` worked well for me.

EDIT: I also read that the incompatibility will probably not be fixed until Nextcloud 23, so a proper fix would probably be preferrable compared to everybody being hit by this issue.
Comment by Caleb Maclennan (alerque) - Tuesday, 20 July 2021, 11:47 GMT
For those hitting or about to hit this, the setting in question can't be set in 10.5 before you upgrade because it is a new setting. You can add this to `server.cnf` at the end to avoid breakage before you run the package upgrades:

Comment by Giovanni Harting (IdleGandalf) - Tuesday, 20 July 2021, 12:09 GMT Comment by David Runge (dvzrv) - Wednesday, 21 July 2021, 20:10 GMT
@Taijian: Thanks for the report!

It seems there is not much we can do about it for now.
I have added a section in the troubleshooting section to address this:
Comment by David Runge (dvzrv) - Friday, 04 February 2022, 21:47 GMT
It seems a relevant change has now been merged and will indeed be made available for nextloud 24:
Comment by Lex Black (TrialnError) - Wednesday, 16 February 2022, 10:45 GMT
This issue in general may be resolved.
mariadb seems to have switched their position on the deprecation and removal. The release notes[1] for 10.6.6 states the following: Allow seamless upgrade despite ROW_FORMAT=COMPRESSED[2]
It was also mentioned in the issue of the nextcloud server repo[3]

So as of mariadb 10.6.6 and above (in repos) this should not be of concern anymore.