Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71487 - Host crashes when running a GVT-g guest VM

Attached to Project: Arch Linux
Opened by David Garfias (davidgarfias) - Monday, 12 July 2021, 15:19 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 13 July 2021, 17:33 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Description: The system crashes (host) when running a GVT-g guest (VM). According to the GVT-g mantainer, the regression was introduced by a commit in kernel version 5.12, so one solution could be to reverse the commit.



Additional info:
* linux 5.12
* https://github.com/intel/gvt-linux/issues/188#issuecomment-877300477
This task depends upon

Comment by loqs (loqs) - Monday, 12 July 2021, 20:56 GMT
This would revert a commit [1] for unrecoverable GPU hangs that is still applied in mainline without there being an alternate fix.
Would this break more systems that at fixes? I would suggest reverting the commit locally until the issue is resolved upstream.

[1] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=58586680ffadc37636120d9f59955aa5f7a32b7d
Comment by Jan Alexander Steffens (heftig) - Tuesday, 13 July 2021, 19:22 GMT
I don't think reverting this in the distro kernel is a good idea, since GVT-g is such an obscure feature.

Loading...