Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71485 - [docker] missing `docker scan` recommended by upstream

Attached to Project: Community Packages
Opened by Eric Engestrom (1ace) - Monday, 12 July 2021, 10:16 GMT
Last edited by Sébastien Luttringer (seblu) - Wednesday, 04 August 2021, 08:29 GMT
Task Type Feature Request
Category Packages
Status Assigned
Assigned To Sébastien Luttringer (seblu)
Morten Linderud (Foxboron)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

A couple Docker releases ago (20.10.6), they had the following [packaging note](https://docs.docker.com/engine/release-notes/#20106):
> Provide the [Docker Scan CLI](https://github.com/docker/scan-cli-plugin) plugin on Linux amd64 via a `docker-scan-plugin` package as a recommended dependency for the `docker-ce-cli` package [docker/docker-ce-packaging#537](https://github.com/docker/docker-ce-packaging/pull/537)

It would be great if the Arch package followed this recommendation :)
This task depends upon

Comment by Sébastien Luttringer (seblu) - Wednesday, 04 August 2021, 08:52 GMT
We don't have such a recommendation mechanism in Arch Linux. We only have optional dependencies.
We could add a package named docker-scan-plugin (or better docker-plugin-scan) to the optdepends but there is no such package in the Arch Linux repositories.
So, until someone is interested in maintaining the scan plugin in the official repositories, I'll not add it.

Loading...