Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71483 - [Xorg] Xorg crashes when opening new window with update 1.20.12-1

Attached to Project: Arch Linux
Opened by Radek Šťasta (Raadush) - Sunday, 11 July 2021, 18:28 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 29 July 2021, 19:21 GMT
Task Type Bug Report
Category System
Status Closed
Assigned To Andreas Radke (AndyRTR)
Sven-Hendrik Haase (Svenstaro)
Laurent Carlier (lordheavy)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description: After I update Xorg to 1.20.12-1, Xorg crashes. I use Arch Linux with xmonad window manager. See attached journalctl export and Xorg log. I can provide any other additional output if you want it, happens all the time, easily reproducible.


Additional info:
* package version(s)
* config and/or log files etc.
* link to upstream bug report, if any

Steps to reproduce:
1. Install xorg version 1.20.12-1
2. Open new application window (terminal, browser,...)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Thursday, 29 July 2021, 19:21 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Monday, 12 July 2021, 05:23 GMT
If you can confirm this is caused by the Xorg-server update please report this upstream: https://gitlab.freedesktop.org/xorg/xserver/-/issues but the Xorg update can also cause to uncover a bug in xmonad or nvidia driver.
Comment by Radek Šťasta (Raadush) - Monday, 12 July 2021, 05:29 GMT
How do I confirm that? I can see Segmentation fault in Xorg log, and some fatal errors regarding Xorg in journalctl
Comment by Andreas Radke (AndyRTR) - Monday, 12 July 2021, 05:59 GMT
Please downgrade the related Xorg-server packages and check if it keeps to crash with a segfault.
Comment by Sven-Hendrik Haase (Svenstaro) - Monday, 12 July 2021, 06:23 GMT
Also note that regarding the nvidia driver, we can't really do anything about this as it's a binary blob.
Comment by Radek Šťasta (Raadush) - Monday, 12 July 2021, 07:28 GMT
No problem with 1.20.11-1 (all other packages updated to latest version including nvidia), after updating Xorg to 1.20.12-1, it keeps crashing again
Comment by Frederic Bezies (fredbezies) - Monday, 12 July 2021, 08:12 GMT
I can confirm this issue in a Qemu virtual machine with Archlinux and Xfce. With xorg-1.20.12-1, xfce won't load and get back to lightdm. With Xorg-1.20.11-1, I can log in Xfce. Used video driver is QXL one.

While analysing the coredump file, I got an output that I added as an attachment.

GDB backtrace is empty because I do not have a debug enabled version of xorg-server.
Comment by Radek Šťasta (Raadush) - Monday, 12 July 2021, 08:24 GMT
Comment by Frederic Bezies (fredbezies) - Monday, 12 July 2021, 09:24 GMT
Got a debug stacktrace. Adding it to this comment.

Bug opened on xorg tracker: https://gitlab.freedesktop.org/xorg/xserver/-/issues/1195
Comment by Frederic Bezies (fredbezies) - Monday, 12 July 2021, 12:42 GMT
After Philip Muller asked for a git bisect, I was able to find the first broken commit and the last working one on xorg-server 1.20 branch.

https://gitlab.freedesktop.org/xorg/xserver/-/issues/1195#note_988297

```
Last working commit: 4e11bd39 - modesetting: Disable reverse prime offload mode for displays running on evdi,udl
First broken commit: 464cbee1 - modesetting: Initialize present extension despite glamor is disabled
```

It is related to the use of modesetting and Glamor?!

Weird.
Comment by Vasiliki Katsageorgiou (vkatsageorgiou) - Tuesday, 13 July 2021, 11:32 GMT
I also noticed some problem after I updated my system yesterday. I use to work with 2 external monitors connected to my laptop. After I updated my system yesterday, if I have the second monitor connected, it logs out and I try to login it keeps logging me out. If I have only one external monitor connected as duplicate of the laptop screen, it works. I downgraded xorg to 1.20.11 and it seems to be working for now. Though once it happened that I could not enter the password in the login page having both the external monitors connected. I disconnected them and I managed to login without rebooting.
Comment by Vasiliki Katsageorgiou (vkatsageorgiou) - Tuesday, 13 July 2021, 11:43 GMT
I also noticed some problem after I updated my system yesterday. I use to work with 2 external monitors connected to my laptop. After I updated my system yesterday, if I have the second monitor connected, it logs out and I try to login it keeps logging me out. If I have only one external monitor connected as duplicate of the laptop screen, it works. I downgraded xorg to 1.20.11 and it seems to be working for now. Though once it happened that I could not enter the password in the login page having both the external monitors connected. I disconnected them and I managed to login without rebooting.
Comment by f (bakgwailo) - Thursday, 15 July 2021, 21:42 GMT
I am going to add on to this: finally restarted my laptop today (Optimus, running the official nvidia method), and on reboot SDDM starts up fine, but X/KDE seg faults with a similiar error message. I tried a brand new user and same issue (along with the latest stable kernel and the lts kernel). I switched to plasma-wayland in SDDM and I am able to login in fine. Startx from the CLI also crashes in the same way, so, it does seem like to be a regression in Xorg.
Comment by Frederic Bezies (fredbezies) - Thursday, 29 July 2021, 08:09 GMT Comment by Laurent Carlier (lordheavy) - Thursday, 29 July 2021, 08:47 GMT
Please test xorg-server-1.20.12-2
Comment by Frederic Bezies (fredbezies) - Thursday, 29 July 2021, 09:07 GMT
Fixed for me. I can login into a Xfce in a Virtual Machine with this version of xorg-server. No more crashes and going back to lightDM.

Loading...