Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71470 - [fish] broken `set` validation logic

Attached to Project: Community Packages
Opened by George Tsiamasiotis (gtsiam) - Thursday, 08 July 2021, 12:20 GMT
Last edited by Felix Yan (felixonmars) - Thursday, 08 July 2021, 14:09 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Levente Polyak (anthraxx)
Filipe Laíns (FFY00)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There can be an annoying warning when using `set` in fish 3.3.0 due to some broken validation logic.
Also breaks nix-env (https://github.com/lilyball/nix-env.fish/issues/8).

This is fixed upstream, we just need to update to 3.3.1.

Additional info:
* Package: fish 3.3.0-1
* Upstream bug (fixed in 3.3.1): https://github.com/fish-shell/fish-shell/issues/8095

To reproduce, run:
$ set PATH /usr/local/bin:/usr/bin
set PATH /usr/local/bin:/usr/bin
set: Warning: $PATH entry "/usr/local/bin:/usr/bin" is not valid (No such file or directory)
set: Did you mean 'set PATH $PATH /usr/bin'?
This task depends upon

Closed by  Felix Yan (felixonmars)
Thursday, 08 July 2021, 14:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  fish-3.3.1-1
Comment by George Tsiamasiotis (gtsiam) - Thursday, 08 July 2021, 12:22 GMT
I thought I wrote a proper title - guess I didn't. Well, I see no way to change it now, so uh... sorry?
> [fish] broken `set` validation logic
Comment by Eli Schwartz (eschwartz) - Thursday, 08 July 2021, 13:49 GMT
Fixed

Loading...