Release Engineering


FS#71416 - Archiso build zfs ISO DKMS fail

Attached to Project: Release Engineering
Opened by mark (qinohe) - Friday, 02 July 2021, 01:00 GMT
Last edited by David Runge (dvzrv) - Friday, 18 February 2022, 18:24 GMT
Task Type Bug Report
Category ArchISO
Status Closed
Assigned To David Runge (dvzrv)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Building a ZFS ISO using kernel Linux-LTS fails with the newest Archiso packages.

Bisecting was done on an x86_64 machine
Running the program was done on an 'systemd-nspawn' container.

archiso-git-55.r10.g9c44ae fails
archiso-55-1 succeeds

Bisecting between V54 and V55 all versions are good

Bisecting between V55 and V56 all versions are bad
archiso-git-55.r10.g9c44aee-1-any.pkg.tar.zst -bad
archiso-git-55.r5.g6f671e1-1-any.pkg.tar.zst -bad
Bisecting further all versions install but give build problems:

[mkarchiso] INFO: Installing packages to '/home/isouser/archiso/working/zfsiso-work/x86_64/airootfs/'...
/usr/bin/mkarchiso: line 332: ARCHISO_GNUPG_FD: unbound variable

[mkarchiso] INFO: Installing packages to '/home/isouser/archiso/working/zfsiso-work/x86_64/airootfs/'...
/usr/bin/mkarchiso: line 332: ARCHISO_GNUPG_FD: unbound variable

So I can't say for sure if the problem is in 55.r1 or 55.r2

Hope this is enough to figure out what the issue might be.

for more info:
Thanks, Mark
This task depends upon

Closed by  David Runge (dvzrv)
Friday, 18 February 2022, 18:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with archiso 57
Comment by David Runge (dvzrv) - Friday, 02 July 2021, 08:23 GMT
@qinohe: Thanks for the report!

Depending on whether you PGP sign the rootfs image the build may fail up until the unbound variable was fixed [1].
If you experience issues with commits beyond that [2], please also include a specific error message and/or the entire build log (when running mkarchiso using the verbose option flag).

FWIW, the first commit after v55 [3] fixes  FS#70580  by unsetting the environment variables and only providing the ones we specifically want before calling pacstrap.

Comment by mark (qinohe) - Friday, 02 July 2021, 11:36 GMT
@David Runge, thanks for your response.

Now I see my report made you think I had a problem with PGP signing...
Did add a link and my header was clear but I see now that the DKMS module error should have been added too, sorry bout that!

nl6720, did provide a preview patch / merge request:
I did already try it and it does solve the problem, the ZFS modules being build.

Again sorry I wasn't more clear.
Regards, Mark
Comment by David Runge (dvzrv) - Friday, 02 July 2021, 12:12 GMT
@qinohe: No problem. In the case of those two script outputs your issue is definitely, that the variable ARCHISO_GNUPG_FD is unset if not PGP signing the rootfs.

The underlying problem seems to be though, that we have also unset PATH in that first commit after v55, which nl6720 currently attempts to fix and then we'll close this issue :)
Comment by mark (qinohe) - Friday, 02 July 2021, 12:29 GMT
@David Runge,
Refreshing double posts!

I did get the message about the unset PATH, glad if that's solved too;)
Regards, Mark

edit: after installing 56.r8.g1b01d22 the issue was solved.
I had no errors, ISO is booting fine, had no unbound variables during building.
Thanks for the quick response from the Archiso team.
Regards, Mark