Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71394 - [linux] [linux-hardened] [linux-lts] AMDGPU idle state issues

Attached to Project: Arch Linux
Opened by David Runge (dvzrv) - Tuesday, 29 June 2021, 10:03 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 05 July 2021, 11:50 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Jan Alexander Steffens (heftig)
Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: Due to a regression introduced in 5.13-rc7 and backported to 5.12.13 and 5.10.46 a set of AMDGPUs (GFX10, GFX9) are no longer able to enter idle state which leads to them consuming their maximum amount of power and potentially overheating which may result in hardware defects.

At the time of writing all kernels in the official repositories are affected by this issue.

Additional info:
* linux 5.12.13-arch1-2, linux-hardened 5.12.13-hardened1-1, linux-lts 5.10.46-1
* https://bugzilla.kernel.org/show_bug.cgi?id=213561

Steps to reproduce:
Install any of the above kernels leading to the graphics card utilization maxing out (on affected hardware).
The increase in power consumption and utilization may be observed in radeontop.

These two commits need to be reverted (link to linux-hardened for convenience):
* https://github.com/anthraxx/linux-hardened/commit/ee85fdbcea82317c74bd5257de3946abb1fd1c2f
* https://github.com/anthraxx/linux-hardened/commit/df6cd610bbe52fc78bd77fec67850f0f3497679d
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 05 July 2021, 11:50 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 5.12.14.arch1-1 linux-hardened 5.12.14.hardened1-1 linux-zen 5.12.14.zen1-1

Loading...