Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71386 - [kodi] VDPAU decoding not available

Attached to Project: Community Packages
Opened by Greg (Greg0) - Monday, 28 June 2021, 20:43 GMT
Last edited by Ike Devolder (BlackEagle) - Thursday, 15 July 2021, 17:27 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

VDPAU decoding not available in recent versions, see:
https://bbs.archlinux.org/viewtopic.php?id=267315

Commenting out the wayland, and gbm builds in the PKGBUILD, and just building x11 produces a package that has VDPAU available, and working.

Not sure exactly which package version was first affected sorry, but I think it must have been either 19.0-6, or 19.0-9. I note that the order of the wayland, gbm, and x11 builds was changed in 19.0-9, could this be the cause?

Have attached a copy of my modified PKGBUILD (also tweaked to update the change in file name of the upstream source, as per https://bugs.archlinux.org/task/71222)

Additional info:
* package version(s): 19.1-1, 19.0-9, 19.0-6?
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Thursday, 15 July 2021, 17:27 GMT
Reason for closing:  Fixed
Additional comments about closing:  19.1-5 is released with a fix
Comment by Greg (Greg0) - Monday, 28 June 2021, 21:11 GMT
Sorry, should have added, had to patch to build with Java 16:
https://github.com/xbmc/xbmc/pull/19885/files
Comment by John (graysky) - Friday, 02 July 2021, 17:06 GMT
I believe the VDPAU stuff is due to the explanation here: https://forum.kodi.tv/showthread.php?tid=363364&pid=3046822#pid3046822

Pasting it here:

asavah wrote:
As I suspected arch pkgbuild is somewhat sloppy https://github.com/archlinux/svntogit-co...#L115-L140,
it does not list vdpau as a direct dependency and it does not explicitly enable needed features relying on the magic of autodetection (IMO a very bad thing for packaging).
Kodi ppa explicitly enables all the needed features at configure time eg -DENABLE_VAAPI=ON -DENABLE_VDPAU=ON
The resulting Arch binary is *not* linked to libvdpau.

Arch binary
readelf -d kodi-x11 | grep NEEDED | grep vdpau
^^ Nothing, no vdpau here

Kodi ppa
readelf -d kodi.bin | grep NEEDED | grep vdpau
0x0000000000000001 (NEEDED) Shared library: [libvdpau.so.1]
Comment by Ike Devolder (BlackEagle) - Tuesday, 06 July 2021, 06:53 GMT
So the whole autodetect does not work, because libvdpau is there at compile time.

Loading...