Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71384 - bpython depends on python-pyxdg

Attached to Project: Community Packages
Opened by Finn Elija (finn_elija) - Monday, 28 June 2021, 15:00 GMT
Last edited by Antonio Rojas (arojas) - Monday, 27 December 2021, 09:52 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Kyle Keen (keenerd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Calling bpython results in

Traceback (most recent call last):
File "/usr/bin/bpython", line 33, in <module>
sys.exit(load_entry_point('bpython==0.21', 'console_scripts', 'bpython')())
File "/usr/bin/bpython", line 25, in importlib_load_entry_point
return next(matches).load()
File "/usr/lib/python3.9/importlib/metadata.py", line 77, in load
module = import_module(match.group('module'))
File "/usr/lib/python3.9/importlib/__init__.py", line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File "<frozen importlib._bootstrap>", line 1030, in _gcd_import
File "<frozen importlib._bootstrap>", line 1007, in _find_and_load
File "<frozen importlib._bootstrap>", line 986, in _find_and_load_unlocked
File "<frozen importlib._bootstrap>", line 680, in _load_unlocked
File "<frozen importlib._bootstrap_external>", line 855, in exec_module
File "<frozen importlib._bootstrap>", line 228, in _call_with_frames_removed
File "/usr/lib/python3.9/site-packages/bpython/curtsies.py", line 10, in <module>
from .curtsiesfrontend.repl import BaseRepl
File "/usr/lib/python3.9/site-packages/bpython/curtsiesfrontend/repl.py", line 34,in <module>
from bpython.repl import (
File "/usr/lib/python3.9/site-packages/bpython/repl.py", line 45, in <module>
from .config import getpreferredencoding
File "/usr/lib/python3.9/site-packages/bpython/config.py", line 31, in <module>
from xdg import BaseDirectory
ModuleNotFoundError: No module named 'xdg'

Installing extra/python-pyxdg fixes this. Additionally, pyxdg is noted as required in “Changes to dependencies:” near the end of this site: https://github.com/bpython/bpython/releases/tag/0.21-release
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 27 December 2021, 09:52 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#70472 
Comment by Robin Trioux (Vial) - Sunday, 08 August 2021, 22:13 GMT
Just had the same issue. Please maintainer just add `python-xdg` as a dependency.

Loading...