Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#7137 - Update/pacman3 kills rc.conf

Attached to Project: Pacman
Opened by Johannes Jordan (FoPref) - Saturday, 12 May 2007, 10:52 GMT
Last edited by Aaron Griffin (phrakture) - Tuesday, 30 October 2007, 16:06 GMT
Task Type Bug Report
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity High
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After updating yesterday, including pacman3, I couldn't restart my network properly. I found out the config was wrong. The file rc.conf was completely new. There was also rc.conf.pacnew, which was exactly the same file.
   pacman.log (395.4 KiB)
This task depends upon

Closed by  Aaron Griffin (phrakture)
Tuesday, 30 October 2007, 16:06 GMT
Reason for closing:  Not a bug
Additional comments about closing:  See final comments
Comment by Xavier (shining) - Sunday, 20 May 2007, 09:13 GMT
This could be a side effect of  bug 7133  .
On postinstall of pacman3, a script in pacman.install is executed for fixing the md5sums in pacman database, and it relies on pacman -Qo
An invalid entry in pacman database could mess up pacman -Qo output and break this script.
Note, that's just one possibility of what could have went wrong during pacman 3 upgrade, and this happened to other users.
It could be something totally different in this case, it's hard to tell without having the output of pacman.install , which appears to be missing from your pacman.log (maybe this is logged only with pacman 3).

To see if it's the case here, try running for example :
pacman -Qo /etc/rc.conf
If this works fine, supposing for example that you've pacman-3.0.4-2 installed, you could try running the script again like this :
sh /var/lib/pacman/local/pacman-3.0.4-2/install _resetbackups
Comment by Johannes Jordan (FoPref) - Saturday, 21 July 2007, 18:00 GMT
The comment applies to my problem.

I reran the install script as described. It indeed didn't work correctly the first time. Thank you!
Comment by Aaron Griffin (phrakture) - Tuesday, 30 October 2007, 15:41 GMT
Can this be closed?
Comment by Dan McGee (toofishes) - Tuesday, 30 October 2007, 15:52 GMT
It looks like it. Any objections? Let's give it 24 hours.
Comment by Johannes Jordan (FoPref) - Tuesday, 30 October 2007, 15:56 GMT
As this issue was related to the transition to pacman3, which should be history for almost all users anyway, I too suggest to close this.
Comment by Roman Kyrylych (Romashka) - Tuesday, 30 October 2007, 15:58 GMT
yeah, let's close those old and/or hardly reproduceable reports

Loading...