Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71339 - [podman-docker] DOCKER_HOST needs to contain the rootless podman socket

Attached to Project: Community Packages
Opened by Martin Dünkelmann (MartinX3) - Wednesday, 23 June 2021, 08:45 GMT
Last edited by Morten Linderud (Foxboron) - Friday, 09 July 2021, 12:39 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Morten Linderud (Foxboron)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Podman supports rootless docker-compose since 3.2.0

DOCKER_HOST needs to be filled with "unix:///run/user/${userid}/podman/podman.sock" or docker-compose will die with "permission denied" errors.

Or maybe the docker.sock linked to the rootless podman.sock?

Probably a switch in a config file would be good.

In the arch wiki is no entry about this package.

Additional info:
* 3.2.1-1
* config and/or log files etc.
* https://github.com/containers/podman/issues/10757

Steps to reproduce:
- Creating a postgres compose file.
- docker-compose up
- permission denied errors
This task depends upon

Closed by  Morten Linderud (Foxboron)
Friday, 09 July 2021, 12:39 GMT
Reason for closing:  Won't fix
Comment by Morten Linderud (Foxboron) - Monday, 28 June 2021, 20:09 GMT
I'm not convinced this is a downstream issue frankly. Dan already explains that mimicking docker.socket in rootless mode was never thought off so there is something missing from upstream.

I need to check what other distros does.
Comment by Morten Linderud (Foxboron) - Friday, 09 July 2021, 12:39 GMT
I mentioned how to set `DOCKER_HOST` manually in the wiki. Closing as Wont Fix since we can't deal with this in the package.

Loading...