Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71284 - [mednafen] - dependency change needed

Attached to Project: Community Packages
Opened by Siegfried Metz (NiceGuy) - Thursday, 17 June 2021, 23:36 GMT
Last edited by Jonathan Steel (jsteel) - Thursday, 24 February 2022, 08:49 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jonathan Steel (jsteel)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

In the latest versions of mednafen, since upstream release 1.27.0, the dependency of libsndfile is no longer needed and has been changed upstream to directly depend on flac, which provides libFLAC. Hence libsndfile should be changed to flac in the depends array of the PKGBUILD.


Upstream correspondent changelog snippet below.

"Notable changes since 1.26.1:
Dropped usage of and dependency on libsndfile, and added a direct dependency on libFLAC. The only CD image audio file formats/encodings other than raw supported now are: FLAC, Ogg Vorbis, Musepack, and uncompressed PCM in AIFF/AIFC, AU/SND, W64, and WAV."

Additional info:
* mednafen >= 1.27.1-1
* https://mednafen.github.io

Steps to reproduce:
Rebuild mednafen without libsndfile dependency, should be working as before.
This task depends upon

Closed by  Jonathan Steel (jsteel)
Thursday, 24 February 2022, 08:49 GMT
Reason for closing:  Implemented

Loading...