Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71282 - [cyrus-sasl-gssapi] 2.1.27-4 is missing sasl mechanism GSS-SPNEGO

Attached to Project: Arch Linux
Opened by A. Bosch (progandy) - Thursday, 17 June 2021, 20:39 GMT
Last edited by Antonio Rojas (arojas) - Friday, 18 June 2021, 07:11 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Allan McRae (Allan)
Antonio Rojas (arojas)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
cyrus-sasl-gssapi is missing support for GSS-SPNEGO, which is required for interaction with some windows domains using e.g. adcli.

This is caused by an autoconf failure. The configuration in the package is incompatible with autoconf 2.70 and that results in messages like

> checking for SPNEGO support in GSSAPI libraries... ./configure: line 18853: ac_fn_c_try_run: command not found
> no

It seems to be a coincidence that the rest of the build succeeded with those errors present.

The bug is fixed with this upstream pull request (not merged yet)
https://github.com/cyrusimap/cyrus-sasl/pull/644

I can confirm that the patches allow building cyrus-sasl-gssapi with apparent GSS-SPNEGO support (only verified with pluginviewer)


Additional info:
* package cyrus-sasl-gssapi - 2.1.27-4
* discovered in https://bbs.archlinux.org/viewtopic.php?id=267252
* log with build error: https://reproducible.archlinux.org/api/v0/builds/97418/log
* related fedora bug: https://bugzilla.redhat.com/show_bug.cgi?id=1943013


Steps to reproduce:
Install cyrus-sasl and cyrus-sasl-gssapi, then run

pluginviewer -c -m GSS-SPNEGO
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 18 June 2021, 07:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  cyrus-sasl 2.1.27-5
Comment by A. Bosch (progandy) - Thursday, 17 June 2021, 20:51 GMT
diff adding the patches to the PKGBULD

Loading...