Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71277 - [scribus] Scribus crashed with signal 11

Attached to Project: Community Packages
Opened by Mario Santos (lcv) - Thursday, 17 June 2021, 00:29 GMT
Last edited by Antonio Rojas (arojas) - Thursday, 17 June 2021, 19:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
When i opened Scribus, this freezes.
Also, when i used Appimage version, also crashes.
Config and cache cleaned, same results.


Additional info:
* package version(s)
* config and/or log files etc.
scribus
sizeof(TrkHeader)=1000
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_gdal.so' exists, but an error occurred while trying to open it:
libgdal.so.29: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
ReaderWriterTF::writeObject
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_ogr.so' exists, but an error occurred while trying to open it:
libgdal.so.29: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found
qt.gui.icc: Unsupported ICC profile class 70727472
QPngHandler: Failed to parse ICC profile
Scribus Crash
-------------
Scribus crashes due to Signal #11


* link to upstream bug report, if any

Steps to reproduce:
- System up to date
- Open Scribus
This task depends upon

Closed by  Antonio Rojas (arojas)
Thursday, 17 June 2021, 19:54 GMT
Reason for closing:  Works for me
Comment by Mario Santos (lcv) - Thursday, 17 June 2021, 00:33 GMT
BTW, version is:

1.5.6.1-14
Comment by vmc (felidae) - Thursday, 17 June 2021, 01:23 GMT
I have the same problem, but when I run Scribus as superuser it starts.

------------
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_ogr.so' exists, but an error occurred while trying to open it:
libgdal.so.29: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_gdal.so' exists, but an error occurred while trying to open it:
libgdal.so.29: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
ReaderWriterTF::writeObject
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_vnc.so' exists, but an error occurred while trying to open it:
libvncclient.so.1: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio
sizeof(TrkHeader)=1000
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found
qt.gui.icc: Unsupported ICC profile class 70727472
QPngHandler: Failed to parse ICC profile
Comment by Antonio Rojas (arojas) - Thursday, 17 June 2021, 06:26 GMT
If the Appimage also crashes it is not a packaging issue, please report it upstream.
Comment by Mario Santos (lcv) - Thursday, 17 June 2021, 19:50 GMT
ok, today's update fixed the problem. Maybe something with kernel because it was other of the packages updated. Close this.

Loading...