Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71252 - [linssid] 3.6-7 requires an outdated boost library

Attached to Project: Community Packages
Opened by Aleksander Krauze (akrauze) - Monday, 14 June 2021, 04:51 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 14 June 2021, 17:40 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Program linssid installed from package linssid 3.6-7 depends on an outdated boost library. After installation when I try to run linssid I get error message: "linssid: error while loading shared libraries: libboost_regex.so.1.75.0: cannot open shared object file: No such file or directory". Linssid depends on package boost-libs that is currently on version 1.76.0-1 and provides library "libboost_regex.so.1.76.0".

Fixing this problem will probably require only recompiling linssid package.

Additional info:
Output of "pacman -Q linssid boost-libs":
linssid 3.6-7
boost-libs 1.76.0-1

Steps to reproduce:
Download package linssid 3.6-7 and try to run /usr/bin/linssid.

PS.
This is my first bug report. If I made something wrong or should have flagged package outdated and not submit bug please let me know so I don't make this mistakes in the future. I will be happy to provide more detailed information if needed, but frankly I think I have said every thing that could be said. It just needs recompiling.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 14 June 2021, 17:40 GMT
Reason for closing:  Not a bug
Additional comments about closing:  You seem to have an old version of linssid installed. If you update it, it should be fine. :)
Comment by Aleksander Krauze (akrauze) - Monday, 14 June 2021, 05:18 GMT
I can confirm, after I downloaded and compiled source code myself, that this bug only requires recompiling linssid package.
Comment by Eli Schwartz (eschwartz) - Monday, 14 June 2021, 17:39 GMT
linssid 3.6-7 is out of date. The current version at https://archlinux.org/packages/community/x86_64/linssid/ is 3.6-9, it's already been rebuilt for boost (and now no longer links to a shared library, since boost_regex is header-only now).

EDIT: the thaller.ws mirror is syncing improperly due to https://github.com/WayneD/rsync/issues/192

Loading...