FS#71220 - Powertop "cpufreq_stats failedLoaded 750 prior measurements" "/usr/bin/xset: unknown option force"

Attached to Project: Community Packages
Opened by allexj (allexj) - Friday, 11 June 2021, 07:30 GMT
Last edited by Toolybird (Toolybird) - Wednesday, 10 May 2023, 07:34 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I have run powertop --calibrate a lot of times. If I run powertop, it says "cpufreq_stats failedLoaded 750 prior measurements" and after that, it runs. Another thing is that I noticed that when I run powertop --calibrate, at the beginning of calibration the program has this output: "/usr/bin/xset: unknown option force" and I think that this error may make the calibration wrong. In fact, maybe it's related, if I run powertop, I see an high use in terms of watt by Display backlight... maybe it's related.

Additional info:
* package version(s): PowerTOP version 2.14
* Under Wayland, and kernel 5.12.9-arch1-1 (but I have this issue in all kernel that I tried)
This task depends upon

Closed by  Toolybird (Toolybird)
Wednesday, 10 May 2023, 07:34 GMT
Reason for closing:  Upstream
Comment by allexj (allexj) - Sunday, 13 June 2021, 07:43 GMT
other useful info is that if I decrease brightness to minimum, "Display backlight" is always at the same value, like if decreasing brightness does not make any difference.
Comment by Toolybird (Toolybird) - Wednesday, 10 May 2023, 07:34 GMT
Looks like an upstream issue [1].

[1] https://github.com/fenrus75/powertop/issues/110