Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71158 - [pipewire-pulse] chromium/electron application occasional audio breakage

Attached to Project: Arch Linux
Opened by Moritz J (jomority) - Monday, 07 June 2021, 12:39 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 08 June 2021, 12:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since 1:0.3.29-1 some chromium/electron applications seem to have problems with the pipewire pulse server (see upstream issues).
This seems to be fixed with 2a8b7594bc508a1f9af0e2fb3455c3d8dc4de006 [1].
I don't know if upstream plans a point or bugfix release, so it would be nice if you could backport the commit to 1:0.3.29-2 or something similar.

[1] https://gitlab.freedesktop.org/pipewire/pipewire/-/commit/2a8b7594bc508a1f9af0e2fb3455c3d8dc4de006

Steps to reproduce:
* Successively play multiple videos in chromium
* Let discord client idle for 10s and mute/unmute yourself (no sound effect)
* Seek a song in the official spotify client (breaks playback)

Upstream issues:
* https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1258
* https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1267
* https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1274
* https://gitlab.freedesktop.org/pipewire/pipewire/-/issues/1275
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 08 June 2021, 12:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  pipewire 1:0.3.29-2

Loading...