Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#71129 - Malformed German translation on unknown config directives

Attached to Project: Pacman
Opened by Richard Neumann (rne) - Friday, 04 June 2021, 17:51 GMT
Last edited by Allan McRae (Allan) - Monday, 07 June 2021, 04:21 GMT
Task Type Bug Report
Category i18n & l10n
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 6.0.0
Due in Version 6.0.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I discovered this issue when the pacman directive "TotalDownload" was removed with pacman-6.

If you have this now unsupported directive enabled, the German message says:

$ pacman -Q pacman
Warnung: Konfigurations-Datei /etc/pacman.conf, Zeile 35: Direktive »%« in Sektion »TotalDownload« wird nicht erkannt.
pacman 6.0.0-2

Whereas the original English message says:

$ LANG=C pacman -Q pacman
warning: config file /etc/pacman.conf, line 35: directive 'TotalDownload' in section 'options' not recognized.
pacman 6.0.0-2

I did not yet look into the source code, but there seems to be some format string being off.
The "%" should not be there and should contain "TotalDownload", while the "TotalDownload" part should contain the section "options".

Additional info:
* pacman-6.0.0-2

Steps to reproduce:
* Set locale to de_DE.UTF-8
* Add directive TotalDownload to /etc/pacman.conf
* Run any pacman command.
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 07 June 2021, 04:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  Translation fixed in Transifex for pacman-6.0.1
Comment by Richard Neumann (rne) - Friday, 04 June 2021, 17:57 GMT
Yeah, there was an "s" missing:

diff --git a/src/pacman/po/de.po b/src/pacman/po/de.po
index 0f92d87d..93f2cc63 100644
--- a/src/pacman/po/de.po
+++ b/src/pacman/po/de.po
@@ -454,7 +454,7 @@ msgstr ""
msgid ""
"config file %s, line %d: directive '%s' in section '%s' not recognized.\n"
msgstr ""
-"Konfigurations-Datei %s, Zeile %d: Direktive »%« in Sektion »%s« wird nicht "
+"Konfigurations-Datei %s, Zeile %d: Direktive »%s« in Sektion »%s« wird nicht "
"erkannt.\n"

#: src/pacman/conf.c:734
Comment by Eli Schwartz (eschwartz) - Friday, 04 June 2021, 18:40 GMT
  • Field changed: Attached to Project (Arch Linux → Pacman)
  • Field changed: Summary ([pacman] Malformed German translation on unknown config directives → Malformed German translation on unknown config directives)
Pacman has its own project bugtracker, not the "Packages:Core" tracker for reporting bugs about the PKGBUILD used to build it.
Comment by Eli Schwartz (eschwartz) - Friday, 04 June 2021, 18:42 GMT
  • Field changed: Category (Packages: Core → i18n & l10n)
  • Field changed: Reported Version ( → 6.0.0)
  • Field changed: Architecture (All → All)
https://archlinux.org/pacman/translation-help.html

No idea who is on the translation team here, but you could try joining.

Loading...