Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71076 - [qmmp] LADSPA plugin settings are not properly loaded

Attached to Project: Community Packages
Opened by linearithmik (linearithmik) - Tuesday, 01 June 2021, 03:57 GMT
Last edited by Jaroslav Lichtblau (Dragonlord) - Sunday, 08 August 2021, 20:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jaroslav Lichtblau (Dragonlord)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: qmmp `1.5.0-1` introduced a regression where LADSPA plugin settings are not loaded properly after restarting qmmp. This regression was not present in the `1.4.6-1`.

Steps to reproduce:
1. Install `qmmp` and `lsp-plugins` packages
2. Launch `qmmp`
3. Under `Edit -> Plugins -> Effects`, enable the `LADSPA Plugin`.
4. Configure the Parametric Equalizer x16 Stereo (UID=50020076). For example, set the input gain to 0.53.
5. Close the window and verify that enabling/disabling the LADSPA plugin changes the sound. Keep it enabled before the next step.
6. Restart qmmp
7. Navigate to Edit -> Plugins -> Effects -> LADSPA Plugin
8. Observe that the first plugin is selected with the wrong UID.

Additional notes:
I briefly looked at the source code of the plugin. And, I suspect that I found the bug.

In https://svn.code.sf.net/p/qmmp-dev/code/branches/qmmp-1.5/src/plugins/Effect/ladspa/ladspahost.cpp, there is
```
auto it = std::find_if(m_plugins.cbegin(), m_plugins.cend(), [id](LADSPAPlugin *p){ return p->unique_id = id; });
```
I think that it should be
```
auto it = std::find_if(m_plugins.cbegin(), m_plugins.cend(), [id](LADSPAPlugin *p){ return p->unique_id == id; });
```
This task depends upon

Closed by  Jaroslav Lichtblau (Dragonlord)
Sunday, 08 August 2021, 20:28 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in qmmp 1.5.1
Comment by Jaroslav Lichtblau (Dragonlord) - Sunday, 13 June 2021, 16:19 GMT
Does not look like an issue with packaging, was this possibly reported to the upstream project?
Comment by linearithmik (linearithmik) - Sunday, 13 June 2021, 19:02 GMT
I have not reported it upstream. However, I just emailed the maintainer specified in the source code.
Comment by linearithmik (linearithmik) - Thursday, 01 July 2021, 21:34 GMT Comment by linearithmik (linearithmik) - Sunday, 01 August 2021, 02:56 GMT
`qmmp 1.5.1-1` includes the patch for the reported problem. This issue can be closed.

Loading...