Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#7106 - lockup after X shutdown with xf86-video-intel 2.0.0

Attached to Project: Arch Linux
Opened by Björn Martensen (baze) - Wednesday, 09 May 2007, 19:41 GMT
Last edited by Alexander Baldeck (kth5) - Wednesday, 01 August 2007, 22:20 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Alexander Baldeck (kth5)
Architecture i686
Severity High
Priority Normal
Reported Version 0.8 Voodoo
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

with the new xf86-video-intel 2.0.0 driver i sometimes get a total lockup of my laptop when i shutdown. after X is closed, i get strange red and white colored pixels the full width of the screen but only for like 1 or 2cm at the top and the laptop is completely frozen so i have to do a hard shutdown.

this only happens sometimes, i haven't yet figured out what triggers it. if it doesn't lock the system, i get the same pixels but they just flash for <1sec and then everything continues as usual.
this behaviour didn't appear with the older xf86-video-i810 driver _ever_ and when i switch back to that driver, it works fine again, so it must be a driver issue, not hardware related.

my video card is an intel gma 950 in a thinkpad t60.
This task depends upon

Closed by  Alexander Baldeck (kth5)
Wednesday, 01 August 2007, 22:20 GMT
Reason for closing:  Won't fix
Additional comments about closing:  upstream problem, use i810 instead
Comment by Alessio Bolognino (mOLOk) - Thursday, 10 May 2007, 00:19 GMT
I can confirm that (more or less)
My laptop (Apple MacBook Core2 Duo), has an Intel Corporation Mobile 945GM
and when I tried to close Xorg, (ctrl+alt+backspace) it shutdown my machine suddenly.
(Same strange red and white pixels).
Comment by Alexander Baldeck (kth5) - Thursday, 10 May 2007, 10:45 GMT
there have been reports for some apple macbooks not working correctly, supported devices including drawbacks are listed here:

http://www.intellinuxgraphics.org/user.html


I will look into providing your with packages to test out. Would love to fix that apple problem but lack the hardware.
Comment by Alexander Baldeck (kth5) - Thursday, 10 May 2007, 10:59 GMT
Btw, please atach xorg.conf and Xorg.0.log plus wether you made any other tweaks.
Comment by Alexander Baldeck (kth5) - Thursday, 10 May 2007, 13:06 GMT
Ok, here is a repo with xorg-server 1.3.0.0 and corresponding rebuilds:

[xorg]
Server = http://kth5.telekommunisten.net/xorg/

Please try it if you can and report.
Comment by Björn Martensen (baze) - Friday, 11 May 2007, 14:49 GMT
alexander, xorg-server 1.3.0 didn't solve that problem. i still get those strange pixels sometimes. but at least it fixed some other things like switching to fullscreen restarting X, which happened with xf86-intel 2.0.0 and xorg-server 1.2.

after installing your new 2.0.0-3 package, i can't start up X anymore. what did you change in that package? after downgrading to -2 it works again.
Comment by Björn Martensen (baze) - Friday, 11 May 2007, 17:37 GMT
the -4 package works like -2 again. this pixel-error-lockup-situation can be created by just switching to a tty aswell, btw.
Comment by Alexander Baldeck (kth5) - Friday, 11 May 2007, 18:15 GMT
-3 was a problem I've caused. I compiled it against xorg-server 1.2 by accident, sorry bout that. The only real change I've made was adding the install message. For now, I'm researching the problems by trying to compile all your chipsets into a list I can sent to the intellinuxgraphics team. Everybody who has problems with the xf86-video-intel 2.0.0 should consider staying with i810 and block -intel until there is a fix.
Comment by Alexander Baldeck (kth5) - Saturday, 12 May 2007, 12:56 GMT
-5 ready for testing in my xorg repo.
Comment by Alessio Bolognino (mOLOk) - Saturday, 12 May 2007, 13:25 GMT
this is what I get with -4:
compiz: No GLXFBConfig for default depth, this isn't going to work.
compiz: Failed to manage screen: 0
compiz: No manageable screens found on display :0.0

this is with -5:
libGL warning: 3D driver claims to not support visual 0x68
compiz: GLX_EXT_texture_from_pixmap is not supported by direct rendering context, trying indirect rendering context instead

compiz doesn't work, metacity works fine with both
Comment by Alessio Bolognino (mOLOk) - Saturday, 12 May 2007, 14:06 GMT
using the 16 bit depth in xorg.conf beryl-git works, but not compiz-git, so I guess it's an applications problem, not a driver one.
Comment by Alessio Bolognino (mOLOk) - Saturday, 12 May 2007, 19:38 GMT
P.s. beryl works with 24 bit depth too
Comment by Alessio Bolognino (mOLOk) - Monday, 21 May 2007, 13:39 GMT
I'm still testing this driver and I can confirm total lockups when closing X with both xorg7.2 and 7.3
Comment by Alberto Gonzalez (Luis) - Monday, 28 May 2007, 20:02 GMT
I didn't have these problems and have a different intel chipset, but in order to get the new driver to work correctly Ifound that xorg.conf required some changes. So in case it helps in this case:

For example, I want to use a resolution of 1024x768 at 78HZ, so I use the command: gtf 1024 768 78

This gives you a modeline like this one (with your own values):

Modeline "1024x768_78.00" 86.18 1024 1088 1200 1376 768 769 772 803 -HSync +Vsync

Now, in your /etc/X11/xorg.conf add that modeline to your Monitor section, and also add the line (with your values):

Option "PreferredMode" "1024x768_78"

Then in your Device section, add the line (change value for your resolution's height:

Option "CacheLines" "768"

Finally, in your screen section make sure you edit your modes to match the new name of the resolution (in my case, I had to change "1024x768" to "1024x768_78").

These changes + using the new xorg-server-1.3 provided by Alexander Baldeck solved all my problems. I hope it helps here too.
Comment by Björn Martensen (baze) - Monday, 11 June 2007, 18:20 GMT
the problem still persists with packages from testing.
btw, i found that when i switch to a tty from x right after logging in, i get those strange pixels at the top, but they go away and the system doesn't freeze. but after watching a video in totem, it always freezes, when i switch to a tty, suspend or shutdown/restart x. can anyone confirm this? might have something to do with the video backend used by totem, i don't know...

Loading...