Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#71016 - [git] Replace optdep perl-net-smtp-ssl with perl-io-socket-ssl

Attached to Project: Arch Linux
Opened by BTD Master (btdmaster) - Tuesday, 25 May 2021, 20:11 GMT
Last edited by Christian Hesse (eworm) - Wednesday, 26 May 2021, 06:01 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
perl-net-smtp-ssl is not needed for git-send-email TLS support since https://metacpan.org/release/Net-SMTP-SSL has been deprecated in favor of perl's library Net::SMTP. Because perl is a dependency of git regardless, this means that simply installing perl-io-socket-ssl suffices.


Additional info:
git 2.31.1

Steps to reproduce:
1. Remove perl-net-smtp-ssl.
2. Install perl-io-socket-ssl.
3. Try git-send-email.
The email sends successfully.
This task depends upon

Closed by  Christian Hesse (eworm)
Wednesday, 26 May 2021, 06:01 GMT
Reason for closing:  Fixed
Additional comments about closing:  in svn trunk
Comment by BTD Master (btdmaster) - Tuesday, 25 May 2021, 20:48 GMT
Upon further inspection, the optdep perl-mime-tools can be entirely removed with no substitute as git has perl-mailtools as a dependency. (Would it have been better to file a different bug report?)

Loading...