Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70981 - unzip fails with bad extra-field entry

Attached to Project: Arch Linux
Opened by Stuart Little (grobber) - Saturday, 22 May 2021, 03:47 GMT
Last edited by Jonas Witschel (diabonas) - Wednesday, 03 November 2021, 13:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jelle van der Waa (jelly)
Lukas Fleischer (lfleischer)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Running 'unzip -t' on certain archives fails with the error 'bad extra-field entry', where other packaged versions of unzip (e.g. Ubuntu's) do not.

Additional info:
* package version(s): this is about Arch's extra/unzip 6.0-14 package

* config and/or log files etc.: see the error below, under 'steps to reproduce'

* link to upstream bug report, if any: this is not 'upstream', but the issue came up while trying to test a perl module. I opened a github issue at

https://github.com/redhotpenguin/perl-Archive-Zip/issues/88

where there is some additional info. In particular:

(1) Ubuntu 20.04's unzip (also version 6.00) does not error out on this same file;

(2) and nor does a custom-built unzip on this same Arch system, e.g. from the source at

https://github.com/madler/unzip

Steps to reproduce:

try running 'unzip -t' against the attached (jar). The error I receive on my Arch system is

$ unzip -t <path>/plain-test22.zip
Archive: <path>/plain-test22.zip
testing: META-INF/ bad extra-field entry:
EF block length (0 bytes) invalid (< 4)
testing: META-INF/MANIFEST.MF OK
testing: file OK
At least one error was detected in <path>/plain-test22.zip.
This task depends upon

Closed by  Jonas Witschel (diabonas)
Wednesday, 03 November 2021, 13:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  unzip 6.0-15 in [testing]
Comment by Stuart Little (grobber) - Saturday, 22 May 2021, 12:07 GMT
To elaborate on the custom-build comment, I proceed as follows:

(1) retrieve the source for unzip 6.00 (e.g. by cloning https://github.com/madler/unzip or downloading the tar.gz at https://sourceforge.net/projects/infozip/files/UnZip%206.x%20%28latest%29/UnZip%206.0/);

(2) cd into that top folder (on my Arch machine);

(3) copy unix/Makefile into the top directory;

(4) run make generic.

The unzip binary created in that top directory will then *not* choke on the zip file I initially attached.

So the issue is not with unzip itself, but rather with the way it is packaged in Arch. I am not sure if it is an outdated version or some quirky flag combination though.

Loading...