FS#70972 - [python-celery] doesn't work with click 8.0

Attached to Project: Community Packages
Opened by Marcus Hoffmann (BubuIIC) - Friday, 21 May 2021, 22:52 GMT
Last edited by Antonio Rojas (arojas) - Friday, 24 December 2021, 20:41 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Felix Yan (felixonmars)
Filipe Laíns (FFY00)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



See https://github.com/celery/celery/issues/6768

(Now, I didn't actually try updating but I read the flask update notes[1] which mentioned holding back on a hard dependency on click 8 because celery isn't yet compatible, and sure enough someone ran into that problem already)

Additional info:
* package version(s) 5.0.5-2

[1] https://flask.palletsprojects.com/en/2.0.x/changes/#version-2-0-0
This task depends upon

Closed by  Antonio Rojas (arojas)
Friday, 24 December 2021, 20:41 GMT
Reason for closing:  Fixed
Additional comments about closing:  python-celery 5.2.1-1
Comment by Thorben Günther (xenrox) - Sunday, 19 September 2021, 11:42 GMT
This bug still exists on the current package version. It can be fixed by using "https://github.com/celery/celery/archive/refs/tags/v5.1.2.tar.gz" as package source. The bug is caused because celery-5.1.2-py3.9.egg-info/requires.txt locks in an old python-click version. The file was updated in https://github.com/celery/celery/commit/ef026ea44f59e5d234c195c3ce73927f8323f9ee which was backported to the current release, but this package uses an old release tarball.
Edit: Sorry it is not actually backported, I patched and build my own celery version and forgot about it.
Comment by bob (getzze) - Friday, 26 November 2021, 13:14 GMT
This is solved in version 5.2.1:
Comment by bob (getzze) - Friday, 26 November 2021, 14:55 GMT
I tried updating the PKGBUILD and building python-celery-5.2.1
(you also need to update `python-kombu` to v5.2.2).
But I get an error in the test with MongoDB backend that is still unsolved: https://github.com/celery/celery/pull/7041

It seems a problem with the test environment and I could build by disabling the faulty test, by adding this at the end of the `pytest` line:
`--deselect t/unit/backends/test_mongodb.py`