Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70892 - [archiso] Problem with interface configuration for networkd

Attached to Project: Arch Linux
Opened by Romullo (hiukky) - Saturday, 15 May 2021, 23:04 GMT
Last edited by David Runge (dvzrv) - Tuesday, 01 June 2021, 12:18 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Pierre Schmitz (Pierre)
David Runge (dvzrv)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I spent about 2 days racking my brain with Docker in my Arch-based distro! my containers only had access to the internet in host mode, no bridge or other network worked. I spent hours in the week reading about the Network session and couldn't get anywhere, I even thought it could be a DNS resolution problem, I tried some modifications in resolv.conf, I even tried to use the Network manager instead of networkd I did not succeed.

Finally, after a new construction I went to test in Qemu and it was disconnected, being that in previous versions I had it. I decided to download an ISO from another project to confirm and I was also unable to connect.

Summarizing the following commit https://github.com/archlinux/archiso/commit/8a521d0bfaedf16b95c09b4837981c4b567b5118 contains some changes that influenced the problem.

The connection on the host machine works perfectly with this configuration, but in containers and vms that use bridges it does not work.

So after suffering for a while I decided to revert the Match lines to what was before and everything went back to working, containers, vms, other interfaces and so on.

Functional
Name = en *
Name = eth *

Problem
Type = ether

As I said, this was a situation that I tested in my distro, but if possible I would like you to look at it and confirm the problem.

Thanks!
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 01 June 2021, 12:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with archiso 55-1
Comment by nl6720 (nl6720) - Monday, 17 May 2021, 08:07 GMT
If you run:

$ networkctl list

what does it show as the interface's TYPE?
Comment by Romullo (hiukky) - Monday, 17 May 2021, 11:53 GMT
Using name

IDX LINK TYPE OPERATIONAL SETUP
1 lo loopback carrier unmanaged
2 enp2s0 ether routable configured
3 virbr0 bridge no-carrier unmanaged
4 docker0 bridge no-carrier unmanaged
5 br-ac82c76248d8 bridge no-carrier unmanaged
6 br-44ae7e69bf7a bridge routable unmanaged
7 br-55aa2a402822 bridge no-carrier unmanaged
8 br-55d306e687a8 bridge routable unmanaged
9 br-610f608e821f bridge no-carrier unmanaged
10 br-7bda783fdd8c bridge routable unmanaged
12 veth7e47922 ether degraded unmanaged
16 veth6ca5f4b ether degraded unmanaged
18 veth443173f ether degraded unmanaged

Using Type

IDX LINK TYPE OPERATIONAL SETUP
1 lo loopback carrier unmanaged
2 enp2s0 ether routable configured
3 virbr0 bridge no-carrier unmanaged
4 br-55aa2a402822 bridge no-carrier unmanaged
5 br-55d306e687a8 bridge no-carrier unmanaged
6 br-610f608e821f bridge no-carrier unmanaged
7 br-7bda783fdd8c bridge no-carrier unmanaged
8 br-ac82c76248d8 bridge no-carrier unmanaged
9 docker0 bridge no-carrier unmanaged
10 br-44ae7e69bf7a bridge no-carrier unmanaged
14 vethd9d6211 ether degraded configuring
16 veth9fdcd73 ether degraded configuring
18 vethfa2c734 ether degraded configuring

13 links listed.

The first exit is the example work! any of the br * interfaces that appear to be the ones being used are in operational status as "routable", already using type = ether the status is "no-carrier" and the interfaces with vet * are in a setup status " configuring ".
Comment by nl6720 (nl6720) - Monday, 17 May 2021, 12:14 GMT
So the issue is not that Type=ether doesn't match the interface, it's that it matches virtual Ethernet interfaces (veth*) too. This issue was also discovered after I edited https://wiki.archlinux.org/title/Systemd-networkd#Bind_Ethernet_to_bridge to use Type=ether (see the accuracy template).

I guess we'll need to revert back to interface name globbing.
Comment by David Runge (dvzrv) - Saturday, 29 May 2021, 23:14 GMT
This has been fixed with https://gitlab.archlinux.org/archlinux/archiso/-/merge_requests/177 (thanks nl6720).

The commit will be released with v55.
Comment by Romullo (hiukky) - Sunday, 30 May 2021, 01:20 GMT
great!

Loading...