Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70884 - Disc playback not working in Kodi 19.1

Attached to Project: Community Packages
Opened by Stephen E. Baker (TheCycoONE) - Saturday, 15 May 2021, 18:36 GMT
Last edited by Ike Devolder (BlackEagle) - Saturday, 11 September 2021, 15:32 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Ike Devolder (BlackEagle)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Since upgrading from Kodi 18 to Kodi 19.0 Disc playback hasn't been working. The disc menu appears when I insert the disc but pressing Play Disc doesn't result in any action at all.

I asked about it on the Kodi forums but they said that ArchLinux wasn't a supported distro and that I should bring it up here.

There was an upstream bug with disc playback in 19.0 that should have been resolved in 19.1



Additional info:
* package version(s)
kodi-x11 19.1

* config and/or log files etc.
Debug log: https://pastebin.com/SwDLhV3H

* link to upstream bug report, if any
https://forum.kodi.tv/showthread.php?tid=362616&pid=3036843

Steps to reproduce:
Insert DVD
Navigate to DVD menu
Select 'Play Disc'
(nothing happens)
This task depends upon

Closed by  Ike Devolder (BlackEagle)
Saturday, 11 September 2021, 15:32 GMT
Reason for closing:  No response
Comment by Stephen E. Baker (TheCycoONE) - Thursday, 27 May 2021, 23:23 GMT
It appears that kodi is able to play discs now only after they are mounted by an outside process.

Comment by Ike Devolder (BlackEagle) - Thursday, 15 July 2021, 17:29 GMT
Could you check if there is improvement with kodi-19.1-5 ?

Loading...