Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70870 - [ffmpeg] Error after svt-av1 upgrade to version 0.8.7-1

Attached to Project: Arch Linux
Opened by Holger Obermaier (holgerob) - Friday, 14 May 2021, 20:45 GMT
Last edited by Maxime Gauduin (Alucryd) - Thursday, 10 June 2021, 07:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Maxime Gauduin (Alucryd)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After upgrading package svt-av1 to version 0.8.7-1 encoding videos with ffmpeg version 2:4.4-3 fails with the following error:

ffmpeg \
-hide_banner \
-nostdin \
-hwaccel auto \
-i input.mkv \
-f matroska \
-codec:v libsvtav1 \
-rc cqp \
-qp 25 \
-preset 6 \
-map 0:v:0 \
-codec:a copy \
-map 0:a:0 \
out.mkv
...
Error instance 1: Invalid OBMC flag [-1, 0, 1, 2, 3], your input: -64
[libsvtav1 @ 0x5615aeee63c0] Error setting encoder parameters: bad parameter (0x80001005)
SvtMalloc[info]: you have no memory leak
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

After downgrading to svt-av1 version 0.8.6-3 everything works fine again

Maybe ffmpeg needs to be rebuild against the newer version?
This task depends upon

Closed by  Maxime Gauduin (Alucryd)
Thursday, 10 June 2021, 07:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  2:4.4-4
Comment by Holger Obermaier (holgerob) - Saturday, 15 May 2021, 07:46 GMT
Rebuilding ffmpeg after svt-av1 package upgrade without any further modifikations to PKGBUILD resolved the problem for me.
Comment by James Almer (jamrial) - Thursday, 10 June 2021, 02:03 GMT
SVT-AV1 0.8.7 is not ABI compatible with 0.8.6. Many of the public structs, like EbSvtAv1EncConfiguration, were modified in an incompatible way (Fields added in the middle).

ffmpeg needs to be rebuilt using the new 0.8.7 headers.
Comment by Maxime Gauduin (Alucryd) - Thursday, 10 June 2021, 07:02 GMT
Apologies for the delay, this completely slipped my mind. Just pushed a rebuilt package.

Loading...