Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70849 - [linux] Kernel 5.12.3 breaks ath11k via mhi

Attached to Project: Arch Linux
Opened by Ryan Petris (ryanpetris) - Friday, 14 May 2021, 02:11 GMT
Last edited by Jan Alexander Steffens (heftig) - Sunday, 23 May 2021, 11:54 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Kernel 5.12.3 introduced a bug that effectively disables at least the ath11k driver for QCA6390 Wi-Fi cards. To fix the issue, commit 29b9829718c5e9bd68fc1c652f5e0ba9b9a64fed needs to be reverted.

I reported the bug upstream, however I was hoping that Arch could remove this commit in the meantime while it's fixed upstream.

Upstream bug report: https://bugzilla.kernel.org/show_bug.cgi?id=213055

Further details are in the upstream bug report, however the tl;dr; is that I ran a git bisect to find the offending commit, and verified that compiling 5.12.3 with that commit reverted fixes the issue.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Sunday, 23 May 2021, 11:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  5.12.6.arch1-1
Comment by Ryan Petris (ryanpetris) - Friday, 14 May 2021, 02:55 GMT
Tested 5.13-rc1 (via linux-mainline in aur) and Wi-Fi works properly in that version; I guess whatever changes were backported to 5.12 for 5.12.3 either weren't complete or just aren't working as intended.
Comment by Eduard de Jong (jongeduard) - Tuesday, 18 May 2021, 20:59 GMT
Is there any news on this already?

I noticed it too en found this page by google a few days ago. Currently working with a downgrade to 5.12.2 on Arch until I know the issue has been resolved.

Today I just noticed (same machine, multiple operating systems installed) that Fedora's Linux-update to 5.11.20 shows the same issue, so apparently changes like these are ported to older kernels as well. And in this way apparently it wasn't just Arch that didn't prevent the problem to be affecting users.

I was happy that ath11k finally started working well last months. But I guess keeping this driver functional has a bit lower priority than other kernel fixes, since it still shows warnings about being only an experimental driver.
Comment by Jan Alexander Steffens (heftig) - Tuesday, 18 May 2021, 22:46 GMT
Should be fixed in linux 5.12.4.arch2-1
Comment by Eduard de Jong (jongeduard) - Wednesday, 19 May 2021, 17:18 GMT
Well, at least in 5.12.5-arch1-1 it functions again. Didn't try 5.12.4.arch2-1 indeed. Many thanks.
Comment by Mark (ampayne) - Sunday, 23 May 2021, 09:28 GMT
  • Field changed: Percent Complete (100% → 0%)
Bug fixed upstream, revert no longer needed.

The reverted commit was missing a dependency in the upstream kernel. This dependency has now been included in the 5.12.6 kernel. See the discussion here:

87v97dhh2u.fsf@codeaurora.org/T/#u"> https://lore.kernel.org/ath11k/87v97dhh2u.fsf@codeaurora.org/T/#u

It appears that this missing dependency fixes the issue according to the latest message on the original issue board here:

https://bugzilla.kernel.org/show_bug.cgi?id=213055

Given this, you may want to undo the revert just in case this causes other issues.
Comment by Jan Alexander Steffens (heftig) - Sunday, 23 May 2021, 11:54 GMT
This has already happened.

Loading...