Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70818 - [runc] invalid or corrupted package (PGP signature)

Attached to Project: Community Packages
Opened by Sami Kerola (kerolasa) - Wednesday, 12 May 2021, 12:29 GMT
Last edited by Morten Linderud (Foxboron) - Wednesday, 12 May 2021, 12:41 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Package or gpg signature is corrupted.

Additional info:
* runc-1.0.0rc94
* I tried two mirrors: http://mirroir.wptheme.fr/archlinux/$repo/os/$arch and http://arch.yourlabs.org/$repo/os/$arch
* sha256sum /var/cache/pacman/pkg/runc-1.0.0rc94-1-x86_64.pkg.tar.zst
0eaa7602ceef4b0d97a5656a9ba2e4b985cc43be315b7d177d269bd47775af53 /var/cache/pacman/pkg/runc-1.0.0rc94-1-x86_64.pkg.tar.zst
* I seem to be able uncompress and extract tar ballm so I don't think data is corrupted

Steps to reproduce:

$ yay -Suy
[sudo] password for kerolasa:
:: Synchronising package databases...
testing is up to date
core is up to date
extra is up to date
community-testing is up to date
community is up to date
:: Starting full system upgrade...
warning: gnupg: local (2.3.1-1) is newer than core (2.2.27-1)
resolving dependencies...
looking for conflicting packages...

Packages (1) runc-1.0.0rc94-1

Total Download Size: 2.88 MiB
Total Installed Size: 10.48 MiB
Net Upgrade Size: 0.08 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
runc-1.0.0rc94-1-x86_64
(1/1) checking keys in keyring
(1/1) checking package integrity
error: runc: signature from "Morten Linderud <morten@linderud.pw>" is marginal trust
:: File /var/cache/pacman/pkg/runc-1.0.0rc94-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.
error installing repo packages
This task depends upon

Closed by  Morten Linderud (Foxboron)
Wednesday, 12 May 2021, 12:41 GMT
Reason for closing:  Not a bug
Comment by Sami Kerola (kerolasa) - Wednesday, 12 May 2021, 12:31 GMT
Here are the checksums from extracted package.

$ find usr/ -type f | xargs sha256sum
f13a68b9bbbe93e19f47c2b027ddb8d0178145cb931c07f7dfcbfbded6443f6d usr/bin/runc
54814cd8d07d50ef38951af1bec5f678baf4af1b852b5dd21e0f2b0f019db5f3 usr/share/bash-completion/completions/runc
2045a2f2151037ec27eb19d957c7ca6675038d1045ce138dff51d735de941d0e usr/share/man/man8/runc-kill.8.gz
45979e54a8f9729e0983372c628b63f7e1249c32b75ff49e8f48aec9e910e0a6 usr/share/man/man8/runc-ps.8.gz
80b29e0c2facf0f405b13513f1fc231aedd8323ed61f773cf357b57189c3157b usr/share/man/man8/runc-events.8.gz
cea7d25ad3ead13ee04cec0ddf9a6f95affedd74dfe22df879e028c1078e7165 usr/share/man/man8/runc-run.8.gz
52561e21bd67d5a1574eaea7134459ae277fb4ff4b1652a9463e0470af5220fc usr/share/man/man8/runc-restore.8.gz
d48d265826f7ffbd1b6e6d2979516952bd5ad1b5ae3f4a0752041d7878676c0d usr/share/man/man8/runc-update.8.gz
93db99becc4755e99a1f7349634c37d0f90acec977868af9bf641b7a643d0a19 usr/share/man/man8/runc-spec.8.gz
1a55432a7a0bcb492c752dcb917bdb7e93faf2aa6bf6a13e6229d493a79711cb usr/share/man/man8/runc-state.8.gz
fa423b8eae65258de4eaaba911c8e820406da0e7b6de60608dccbc1c0b83b280 usr/share/man/man8/runc-pause.8.gz
90674dac235b713c7d4f713b06a17e3c2f79eb8c33c870d814460a939d1f1da1 usr/share/man/man8/runc-checkpoint.8.gz
6aa3b70e84d9ccbf337739140723315e05b6b9ec6a4f6788ad13e53c8f6ac550 usr/share/man/man8/runc-create.8.gz
a851b78979afb471d3c7e63a75c1d3aea64137ec3280bf5f3fe9ca50c0ef6a50 usr/share/man/man8/runc-exec.8.gz
aad4cde59ff241eefdc36dd165311f12ccb69f2d18fdc3ad003f24233b0d43d9 usr/share/man/man8/runc.8.gz
7e5a823894d35d7b328af5d690dc7588e771737e117a5a08d16beed2fd422b70 usr/share/man/man8/runc-list.8.gz
e0f707d671d3e63b64d5bd1a7d251f058add70dbd55ac3d1eaf16d2b28127fdf usr/share/man/man8/runc-resume.8.gz
35d6281295e4e941be9ee5d97ea881634ef288dcf4c71a2c2a17c086ae9612df usr/share/man/man8/runc-start.8.gz
cc006737b20357aecee126e5c126541ecbe892ce76dfe32043dcc6610cc843ba usr/share/man/man8/runc-delete.8.gz
Comment by Morten Linderud (Foxboron) - Wednesday, 12 May 2021, 12:41 GMT
>warning: gnupg: local (2.3.1-1) is newer than core (2.2.27-1)

https://lists.archlinux.org/pipermail/arch-dev-public/2021-May/030431.html

Please follow [arch-dev-public] if you run with testing enabled.

Loading...