Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#70799 - [git] add git to base-devel

Attached to Project: Arch Linux
Opened by Alexander F. Rødseth (xyproto) - Tuesday, 11 May 2021, 14:34 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 11 May 2021, 17:32 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

git is essential to modern open source software development.

Could it be added to base-devel?
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 11 May 2021, 17:32 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Tuesday, 11 May 2021, 14:40 GMT
essential for development, sure, but not essential for building most packages.
Comment by Andreas Radke (AndyRTR) - Tuesday, 11 May 2021, 17:25 GMT
There's no VCS included in base-devel group so far. Arch devtools pkg pulls them all in now.
I guess our devel-public ML is a better place for such discussions or a RFC at our gitlab.
Comment by Eli Schwartz (eschwartz) - Tuesday, 11 May 2021, 17:31 GMT
Devtools pulls it in because it's needed on the host system to run makepkg --verifysource which doesn't try to do makedepends installation.

There's utterly no reason to require it for compiling PKGBUILDs, especially since git is strictly inferior to tarballs in nearly all cases due to e.g. providing only sha1

This completely misunderstands the basic fundamental of base-devel which is that it's about building packages, not about providing "developer oriented tools".

Loading...